Can't send mail to any external mail addresses

Whilst using NS 7.2. I have found that I can’t send mail to any external mail addresses. Checking the Queue NS module, I can attempt to send any other mail (.com, etc.) but the mail does not get pushed to the Internet.

Sounds weird, can you add some details?
Maillog lines about these attempts might be useful

Later yesterday afternoon, I received a mail back from my server, stating: host[ip address]
refused to talk to me: 554 Your access to
this mail system has been rejected due to the sending MTA’s poor

so it’s not a NS issue…

how do you connect to WAN? is your IP a residential one?
in any case, the answer to your issue is “smarthost”

Assuming the FQDN of your server is not a offical one, but an internal:

Some email-server check the reputation of senders domain and if they can’t get a answer, they refuse the mail. Could this be the problem?

Ok, I have just used to check if my domain / ip is blaclisted.
mxtoolbox resulted is reporting that my domain are missing records in dmarc, blacklisted by Protected Sky and Spamhaus ZEN.

I am connected to the Internet via a domain that is associated to a dynamic DNS (, the domain also is using a alternate-port SMTP and SMTP reflector services provided by

that means that you are inside a room with no windows nor doors… no one will hear you scream… :slight_smile:

you need to use a different smtp host


I think that I might have resolved the problem by adding NO-IPs alternate-port SMTP (ie. into the smarthost section.

1 Like

Might? Or is it definitely resolved?

1 Like

It was resolved after I altered the smarthost, I have sent a couple of (* e-mails and had a couple of confirmations received back from some recipients (as well as a few disposition notifications from other mail recipients).


if you believe that the problem is solved, marks “solved” the answer that helped you.
This helps anyone looking for the same problem and who responds to the support :construction_worker:

thanks @medworthy :wink: