Cant send Attachments via Roundcube Webmailer

roundcubemail
v7
mail

(Uwe) #1

NethServer Version: 7.4 1708
Module: Roundcube

Hi Friends,

it is impossible to send attachments like pdf. word doc or pictures vial roundcube Webmailer or with Outlook via
NS. Who can give me a solution for this problem?

Regards

Uwe


(Markus Neuberger) #2

Hi Uwe,

tried it and you are right with roundcube, mail is sent but without attachements…

Outlook 2016 with IMAP is working
GMail EAS is working

I have some of these errors in /var/log/roundcubemail/errors.log:

[10-Dec-2017 22:04:31 +0100]: <gogjedmc> PHP Error: markus@smart-ict.services can't read /tmp/rcmAttmntc1uOh0 (not in temp_dir) in /usr/share/roundcubemail/plugins/filesystem_attachments/filesystem_attachments.php on line 216 (POST /webmail/?_task=mail&_unlock=loading1512939871697&_lang=de_DE&_framed=1?_task=mail&_action=send)

Edited /etc/roundcubemail/config.inc.php:

#$config['temp_dir'] = '${_tmppath}';
$config['temp_dir'] = '/var/tmp/';

Restarted webserver with “systemctl restart httpd” and sending attachments with Roundcube worked again.
This is just temporary, after a reboot or config change config files are rewritten.

Source:


(Stéphane de Labrusse) #3

you should do a PR in GH or at least to do a bug issue, great shot


(Markus Neuberger) #4

Did a bug issue…

Thanks @transocean, you found a bug!


(Uwe) #5

Wunderfull! Now it works. :

Regards and many thanks…

Sorry for the picture. It should be just for fun.
I did not mean to hurt the feelings of those who lost people in this disaster.

Thanks@Davide

Uwe


(Markus Neuberger) #6

Testing package:

I tested roundcubemail on 2 servers and sending attachments is working.


(Stéphane de Labrusse) #7

Work like a charm, tested on my server.


(Markus Neuberger) #8

Thanks, I saw on github…


(Davide Principi) #9

Bugfix released in 7.4.1708/updates:

nethserver-roundcubemail-1.2.9-1.ns7.noarch.rpm

(Alessio Fattorini) #10

All in 48 hours! Amazing team! :sunglasses:


(Davide Principi) #11

This topic was automatically closed after 4 days. New replies are no longer allowed.