Can't restore configuration on new installation

NethServer Version: 7.6.1810
Module: config-backup

I am trying to simulate a disaster recovery. I just installed a Nethserver VM on Proxmox, with unattended install.

When i try to upload my backup on wizard, i get this:

I think i am missing something

Are you running a VM snapshot? Is the machine clock set correctly?

If that’s not enough, skip the restore step in First config wizard: complete the initial configuration, install updates from Software center, then try the restore from the Backup config page.

Its not a snapshot, its a new VM with fresh installation.

I tried skipping the wizard, adjusted time clock and updated, but I am still geting “The request cannot be completed because this page has expired” :frowning:

This happened to me when i tried to restore a 7.6 setup on a 7.5 install.
Basic setup should have at least one green interface.

It is the same version. I just installed it some days ago, create a DC, some users and groups, and now I’m trying to test a disaster recovery.

Did you follow this steps for the recovery?

  • install from available media
  • full update the installation (this leads to have internet connection on the installation)
  • load the configuration from file (for config restore)
  • configure the hostname as the same as old installation and start the restore

The only step I skipped was to change the hostname.

I tried it now, but it still give the same error.

Where I can find a log with the background error for this message?

I can’t even upload the tar file :frowning:

@davidep is in messages? Or there’s another specific location for the backup/restore Log?

That message is a “CSRF token verification failed!” error. It is an UI problem. You should have it in the messages log file:

grep -B 10 -F 'CSRF token verification failed!' /var/log/messages

Please attach the grep output. Also an excerpt of httpd-admin error log might help…

grep -B 50 -F 'POST' /var/log/httpd-admin/access_log
Jun  5 09:12:29 acde01fs01 httpd: [ERROR] Nethgui\Framework: CSRF token verification failed!
Jun  5 09:12:29 acde01fs01 httpd: [2] POST Content-Length of 80445988 bytes exceeds the limit of 8388608 bytes - File Unknown, line 0
Jun  5 09:15:42 acde01fs01 dhclient[6085]: DHCPREQUEST on eth0 to port 67 (xid=0x5d7d899b)
Jun  5 09:15:42 acde01fs01 dhclient[6085]: DHCPACK from (xid=0x5d7d899b)
Jun  5 09:15:44 acde01fs01 dhclient[6085]: bound to -- renewal in 3158 seconds.
Jun  5 09:43:40 acde01fs01 httpd: [ERROR] Nethgui\Framework: CSRF token verification failed!

It seems like a problem with the size of archive, right?

1 Like

Yes it seems so. Shouldn’t be that big!

Could you look at the archive contents? What are the biggest ones?

1 Like

I put some installation files on “\mydomain\netlogon”, to be used on login scripts :sweat_smile:

I removed them and now the recovery went just fine!

Thank you very much for your support!

1 Like

There’s a “max size” for backup? 8mb?
And… why it’s not reported that the file exceedes the allowed size during backup?

Because that error never happened before :innocent:

80MB of config backup is a faulty use-case IMO.

Limit comes from the procedure of restore or from the upload capacity of nethgui?

It’s the PHP upload limit.