Can't reach joomla site

webserver
mysql

(Michael Träumner) #1

NethServer Version: 7.6
Module: webserver

Hello all,
I’ve setup a webserver and copied a joomla-website to /var/www/html.
Gave all files and folders 755 permissions and apache:apache as owner.
Installed php-scl from Stephane, choose PHP 7.2 for webserver (the original site is running with this) and imported the database to an empty one with the same name, the same user and the same password ass the original one. Changed log and temp directory in configuration.php.
The webserver is an offline-server for presentation of the website without internet. DNS is set and I can reach the server by name, it is redirected to de directory and here I get a 404.
In joomla we have installed zoo with language packs and I think joomla can’t reach the content from the database. Actual version by hosteurope is MySQL 5.6.37-82.2-log. Could this be a compatibility problem with nethserver mariadb?


(Rob Bosch) #2

Just adding 1 and 1 here: if you host mysql/mariadb yourself (what you do with NethServer) you have nothing to do with a mysqlversion used by a hosting provider.
If you have a shared hosting for just a wensite you do use the mysql version of the hosting provider since you get a db created by your hosting provider…
Do you run mysql/mariadb yourself on that server?


(Federico Ballarini) #3

If it is a problem with the url, you can try disabling SEO rewrite.
I have a joomla site on NS without any problem. If u want to show me “what your site is doing” maybe I can help: I’ve just setup a joomla site and solved some problems.

Thanks.


(Michael Träumner) #4

Thanks for your answers.

It’s a shared hosting for just the website. Databases could be created by phpmyadmin.

I’ve a look for it.

Thanks, but before I’ve to speak with my Boss about it.


(Rob Bosch) #5

If I head over to the Joomla website and check the minimum requirements, you should not have a problem with mysql5.6.37


As you can see the minimum requirement is 5.3.10

So long story short, if you can create a database, you should be good with a mysql version 5.6.37


(Markus Neuberger) #6

Maybe the .htaccess file is wrong (still configured for the hosting provider), here is the preconfigured one from the docs:

https://docs.joomla.org/Preconfigured_htaccess


(Federico Ballarini) #7

Comment all Url Rewrite in .htacces
It was one of the problems on my installation. And then I’ve also disabled SEI Rewrite from config file.


(Michael Träumner) #8

I tried this, same error.
Comment all Url Rewrite in .htacces
I also tried this, no chance to get it running. At config i can’t find any SEO rewrite.


(Federico Ballarini) #9

In Joomla configuration.php file I have set this rows:

[…]
public $sef = ‘1’;
public $sef_rewrite = ‘0’;
public $sef_suffix = ‘0’;
[…]

On my file it’s on line 52.
For test, try also to move .htaccess to .htaccess.bak…
Thank you.


(Michael Träumner) #10

Thanks a lot, you saved my time
I didn’t find this before and it did the trick.