Can't reach :8000

v7
webvirtmgr

(Nico Berg) #1

NethServer Version: 7.4
Module: webvirtmgr

Hi there, I want to use webvirtmgr, it worked but after a reboot I can’t reach https://localhostaddress:8000/ any more. So using the button at applications doesn’t work anymore.

Can someone help me out here?

Pit


(Markus Neuberger) #2

Hi @Pitmaster,

as it worked before I assume it’s enabled in web UI? Is the service running?

systemctl status webvirtmgr

Do you have errors in /var/log/messages?

There was another thread some time ago, maybe it’s related:


(Nico Berg) #3

Oke, nice question, result: “Unit webvirtmgr.service could not be found.”…

Pit


(Markus Neuberger) #4

You may try to just remove (maybe it’s already removed) and install again:

yum remove nethserver-webvirtmgr webvirtmgr

yum install nethserver-webvirtmgr


(Nico Berg) #5

No Match for argument: nethserver-webvirtmgr
No Match for argument: webvirtmgr
No Packages marked for removal

Strange, on the webUI it say it is all installed…

Pit


(Stéphane de Labrusse) #6

what is the output of

yum install nethserver-webvirtmgr webvirtmgr


(Nico Berg) #7

Oke, @ stephdl the output of “yum install nethserver-webvirtmgr webvirtmgr” is “Package webvirtmgr-4.8.9-1.192.ge1c7abb.ns7.noarch already installed and latest version
Nothing to do”.
So after the hint mrmarkuz gave everything is installed.
Now the situation is a little changed, on the service page it now look like:
webvirtmgr Disabled Running TCP: 8000
webvirtmgr-console Disabled Running TCP: 5900:5950,16509,6080

They are both running but both status is Disabled. How do I get them enabled?

Pit


(Nico Berg) #8

Found that, still no result, no vm website reachable.

“config setprop nethserver-webvirtmgr status enabled”

My router was using port 8000 for its webinterface… So I have changed the port numbers to 8001 and 8010. Now I have changed the portnumbers for my router to 7500 and do I want my number for the nethserver-webvirtmgr back to normal but I don’t know how I did it the first time and don’t know how to reverse it. :slight_smile:

Pit


(Nico Berg) #9

correct this by editing /var/lib/nethserver/db/configuration

Pit


(Nico Berg) #10

But still no webinterface for KVM. I get crazy.

Pit


(Marc) #11

I think you might be missing this command for the changes to take effect:

signal-event nethserver-webvirtmgr-save

Some more info on webvirtmgr can be found at:


(Nico Berg) #12

More than great!!! That’s it. It works.

Thank you guys, great help. I am happy.

Pitmaster

at the moment finding out how to make virtual machines in here… :slight_smile: