Can't install Nethserver at a proxmox enviremont

NethServer Version: 7.6
Module: Proxmox

Hi to all,
I’ve setup a proxmox and try to install nethserver 7.6 like at the wiki

https://wiki.nethserver.org/doku.php?id=userguide:install_nethserver_on_proxmox_35

I’ve created a vm and connected the nethserver iso file. If I start it and open the console via web gui I’ve a black screen with points moving like a loading bar. If I open the console without starting the vm it looks equal. So I think the iso didn’t start, but I can’t find anything at messages and system log of proxmox.
Has somebody an idea?

Thanks Michael

You may try to start the VM from console to see some error messages:

https://pve.proxmox.com/wiki/Guest_Boot_Problems

Does your machine fulfill the virtualization requirement:

Intel VT/AMD-V capable CPU/Mainboard (for KVM Full Virtualization support)

https://www.proxmox.com/en/proxmox-ve/requirements

1 Like

Hi Markus,
thanks for your answer.
syslog shows the following message:

could not generate persistent mac address for tap…

I think this my problem. Do you have an idea what could get wrong here.

Hi @m.traeumner I just try to replciate your problem, but I am prompted at an anaconda install screen. Can you check the ISO image if it is ok? check md5 hash with the command: md5sum <NAME.ISO>

At sourceforge downloadsite you can compare the MD5sum you find with the one it should be.
When I do the command I get:

md5sum nethserver-7.6.1810-x86_64.iso
f88101b4cafed3e90bff6886f612d859 nethserver-7.6.1810-x86_64.iso

Comparing this with the MD5 file on sourceforge:

f88101b4cafed3e90bff6886f612d859 nethserver-7.6.1810-x86_64.iso

So my download looks fine (which is expected since I get a normal anaconda screen when starting the VM with the ISO)

Looking this errormessage up in combination with proxmox, I get some hits on this subject. However, the general consensus is that this error can be ignored. I don’t think it is related with your problem?

2 Likes

Yes I think so, I’ve installed ubuntu host with libvirt and nethserver guest at an equal system.

But one idea I have is that something goes wrong by proxmox installation, because I’ve forgotten to activate virtualization at the CPU settings at the BIOS and did it after installation of proxmox.
I think I’ll try to reinstall proxmox and try it again.

Thanks for your answer Rob,
I checked md5 checksum and it is the right one.

Hi guys, thanks for your help. I’ve solved my problem now.

At the client I tried to start the vm from, there was only an internet explorer installed, which couldn’t connect to the vm. After trying it with Firefox everything works fine.

Greets Michael

PS: I’ve adapted the wiki article with the hint of not using the Internet Explorer.