Cant bind to ldap

First let me say that I am really liking nethserver. I’m coming from zentyal 5. The spam filter is actually working! I though something was wrong with my setup because I stopped getting so much spam. Installing letsencrypt was super easy, I never did get it working on zentyal and had to use self signed certs.

Well done Nethserver devs!

However, I am stuck on binding computers to LDAP. Probably because I don’t know what i’m doing. Nethserver is my local ldap server.
I see this under Domain accounts:

DAP URI: ldap://
Base DN
User DN
Group DN
Bind DN
Bind password

from an Ubuntu machine I can tenlet 389 and it connects (I think) I get a prompt that says escape character is ‘^]’ Which doesn’t make sense because that is two characters, but OK.

ldapsearch -x -h -D “uid=admin, ou=People, dc=mydomain, dc=com” -W

asks for my password and then says ldap_bind: invalid credentials (49)

I have tried every user name and password in the system with the same results. Any Ideas what might be wrong?

NethServer Version: NethServer release 7.3.1611
Module: ldap

When you installed Samba4 AD accountprovider you had to create a bridge adapter on a green network and provide an IP address. The Samba4 AD accountprovider is a container running on the IP address you chose.
So you need to bind to that container instead of the NethServer IP address.

Probably you need to use TLS.

Use -Z option for ldapsearch or use ldaps:// protocol URI.

1 Like

Furthermore, for LAN clients, LDAP anonymous access is granted to non-sensitive fields. Configuration:

Host: ip address of the server
Port: 389
Base DN: dc=directory,dc=nh

Thanks guys,

The -Z option seemed to do the trick as far as testing the server. I think I still need to do some more reading though to try and get a better understanding of how this all works.

That’s a great intro man :slight_smile: Can you talk about your path all the way out here? Just reply to my last post here:

Great to know, if you need some help just ask. Can you please mark this topic as solved?