Cannot update: no more mirrors to try and 404 errors

Hello , when I install I go to software center but came a error.

what I can do…??

1 Like

Does clear yum cache help?

As a secondary option you could opt to ssh into the server (or log into the server physically) and do a “yum clean all” from the command prompt.

Then to update the server do a "yum update"
These are commands executed as root. If you are not root, but a sudo’er, put “sudo” in front of the command.


Do you have internet access from the server, using a valid DNS. I had a similar error when I accidentally ended up breaking DNS resolution.



happened to me too. :roll_eyes:

@kristian1369 if you can ping it’s not your issue.

1 Like

don´t work

I do what you said… but have some problems…

[root@sdhg ~]# yum clean all
Loaded plugins: changelog, fastestmirror, nethserver_events
Cleaning repos: base centos-sclo-rh centos-sclo-sclo epel extras nethforge
: nethserver-base nethserver-updates updates
Cleaning up everything
Maybe you want: rm -rf /var/cache/yum, to also free up space taken by orphaned d ata from disabled or removed repos
[root@sdhg ~]# yum update
Loaded plugins: changelog, fastestmirror, nethserver_events
base | 3.6 kB 00:00:00
centos-sclo-rh | 2.9 kB 00:00:00
centos-sclo-sclo | 2.9 kB 00:00:00
epel/x86_64/metalink | 3.7 kB 00:00:00
epel | 4.7 kB 00:00:00
extras | 3.4 kB 00:00:00
nethforge | 4.0 kB 00:00:00
nethserver-base | 2.9 kB 00:00:00
nethserver-updates | 4.1 kB 00:00:00
updates | 3.4 kB 00:00:00
(1/14): base/7/x86_64/group_gz | 156 kB 00:00:00
(2/14): centos-sclo-sclo/x86_64/primary_db | 196 kB 00:00:01
(3/14): base/7/x86_64/primary_db | 5.7 MB 00:00:07
(4/14): epel/x86_64/group_gz | 266 kB 00:00:07
epel/x86_64/updateinfo FAILED ] 768 kB/s | 8.8 MB 00:00:18 ETA [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
To address this issue please refer to the below knowledge base article

If above article doesn’t help to resolve this issue please create a bug on

(5/14): extras/7/x86_64/primary_db | 166 kB 00:00:00
(6/14): nethforge/7/x86_64/group_gz | 543 B 00:00:00
(7/14): nethserver-updates/7/x86_64/group_gz | 18 kB 00:00:00
epel/x86_64/primary_db FAILED [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
(8/14): nethforge/7/x86_64/primary_db | 25 kB 00:00:00
(9/14): nethserver-updates/7/x86_64/primary_db | 180 kB 00:00:00
epel/x86_64/updateinfo FAILED [Er rno 14] HTTPS Error 404 - Not Found
Trying other mirror.
epel/x86_64/primary_db FAILED [Errn o 14] HTTPS Error 404 - Not Found
Trying other mirror.
(10/14): centos-sclo-rh/x86_64/primary_db | 3.0 MB 00:00:10
epel/x86_64/updateinfo FAILED ] 756 kB/s | 10 MB 00:00:17 ETA [Errn o 14] HTTPS Error 404 - Not Found
Trying other mirror.
epel/x86_64/primary_db FAILED [Er rno 14] HTTPS Error 404 - Not Found
Trying other mirror.
(11/14): nethserver-base/7/x86_64/primary_db | 241 kB 00:00:01
(12/14): updates/7/x86_64/primary_db | 6.0 MB 00:00:12
Determining fastest mirrors

One of the configured repositories failed (Extra Packages for Enterprise Linux 7 - x86_64),
and yum doesn’t have enough cached data to continue. At this point the only
safe thing yum can do is fail. There are a few ways to work “fix” this:

 1. Contact the upstream for the repository and get them to fix the problem.

 2. Reconfigure the baseurl/etc. for the repository, to point to a working
    upstream. This is most often useful if you are using a newer
    distribution release than is supported by the repository (and the
    packages for the previous distribution release still work).

 3. Run the command with the repository temporarily disabled
        yum --disablerepo=epel ...

 4. Disable the repository permanently, so yum won't use it by default. Yum
    will then just ignore the repository until you permanently enable it
    again or use --enablerepo for temporary usage:

        yum-config-manager --disable epel
        subscription-manager repos --disable=epel

 5. Configure the failing repository to be skipped, if it is unavailable.
    Note that yum will try to contact the repo. when it runs most commands,
    so will have to try and fail each time (and thus. yum will be be much
    slower). If it is a very temporary problem though, this is often a nice

        yum-config-manager --save --setopt=epel.skip_if_unavailable=true

failure: repodata/0042e277848fc53aa21aff85ea54c6194eb844d896e4875e614e7fbdc73ef40c-primary.sqlite.bz2 from epel: [Errno 256] No more mirror s to try. [Errno 14] HTTP Error 404 - Not Found [Errn o 14] HTTPS Error 404 - Not Found [Er rno 14] HTTPS Error 404 - Not Found

This looks like you have a connection problem. Are you sure your DNS client settings are ok?

yes my conection is good, I can do ping to and have respond

this was my solution… rm -rf /var/cache/yum It´s works.



you are right, you do not seem to have DNS or network problems.

To be honest, I do not like the “searching for he fastest mirror” which takes longer then giving the d@mm package; and had this issue quite often building stuff in mock. So i’d hard code centos repos to a reliable mirror nearby, my choice (form the Netherlands) is

that is the blunt tool “clean all”

yes, worked for me.

1 Like