Cannot set imported folders for special use

sogo
v7
mailserver

(sb) #1

Nethserver release: 7.3.1611 (Final)
Module: nethserver-mail-server-1.10.11-1.ns7.noarch, nethserver-sogo-1.6.7-1.ns7.noarch,
nethserver-mail-server-1.10.11-1.ns7.noarch.

My dovecot configuration:

OS: Linux 3.10.0-514.16.1.el7.x86_64 x86_64 CentOS Linux release 7.3.1611 (Core)  
auth_debug = yes
auth_krb5_keytab = /var/lib/dovecot/krb5.keytab
auth_master_user_separator = *
auth_mechanisms = plain login gssapi
auth_verbose = yes
debug_log_path = /dev/null
default_process_limit = 400
disable_plaintext_auth = no
first_valid_uid = 988
imapc_features = rfc822.size fetch-headers
imapc_host = mail.example.com
imapc_master_user = zunga
imapc_password = zunga
imapc_rawlog_dir = /tmp/imaptest
imapc_ssl = starttls
imapc_ssl_verify = no
imapc_user = %u
import_environment = TZ KRB5CCNAME
last_valid_uid = 988
lmtp_save_to_detail_mailbox = yes
mail_gid = vmail
mail_location = maildir:~/Maildir
mail_plugins = " acl listescape fts fts_lucene"
mail_prefetch_count = 20
mail_shared_explicit_inbox = yes
mail_uid = vmail
managesieve_notify_capability = mailto
managesieve_sieve_capability = fileinto reject envelope encoded-character vacation subaddress comparator-i;ascii-numeric relational regex imap4flags copy include variables body enotify environment mailbox date ihave imapflags
mbox_write_locks = fcntl
namespace PUBLIC {
  list = children
  location = maildir:/var/lib/nethserver/vmail/vmail/Maildir:INDEXPVT=~/Maildir/public
  prefix = Public/
  separator = /
  subscriptions = no
  type = public
}
namespace ROOT {
  inbox = yes
  location = 
  mailbox Drafts {
    auto = subscribe
    special_use = \Drafts
  }
  mailbox Flagged {
    auto = no
    special_use = \Flagged
  }
  mailbox Sent {
    auto = subscribe
    special_use = \Sent
  }
  mailbox Trash {
    auto = subscribe
    special_use = \Trash
  }
  prefix = 
  separator = /
  subscriptions = yes
  type = private
}
namespace SHARED_USERS {
  disabled = no
  list = children
  location = maildir:/var/lib/nethserver/vmail/%%u/Maildir:INDEXPVT=~/Maildir/shared/%%u
  prefix = Shared/%%n@example.local/
  separator = /
  subscriptions = no
  type = shared
}
passdb {
  args = /etc/dovecot/master-users
  driver = passwd-file
  master = yes
}
passdb {
  args = dovecot-master
  driver = pam
  master = yes
}
passdb {
  args = /etc/dovecot/deny.passwd
  deny = yes
  driver = passwd-file
}
passdb {
  args = max_requests=100 failure_show_msg=yes blocking=yes
  driver = pam
}
plugin {
  acl = vfile
  acl_shared_dict = file:/var/lib/nethserver/vmail/shared-mailboxes.db
  antispam_backend = MAILTRAIN
  antispam_mail_notspam = ham
  antispam_mail_sendmail = /usr/libexec/nethserver/spam-training.sh
  antispam_mail_sendmail_args = %u
  antispam_mail_spam = spam
  antispam_spam = Junk
  antispam_trash = Trash
  fts = lucene
  fts_lucene = whitespace_chars=@.
  sieve_after = /var/lib/nethserver/sieve-scripts/after.sieve
  sieve_before = /var/lib/nethserver/sieve-scripts/before.sieve
  sieve_extensions = +imapflags
}
protocols = imap lmtp sieve pop3
service anvil {
  client_limit = 1603
}
service auth {
  client_limit = 2000
  unix_listener /var/spool/postfix/private/smtpauth {
    group = postfix
    mode = 0660
    user = postfix
  }
  unix_listener auth-userdb {
    group = vmail
    mode = 0660
  }
}
service dict {
  unix_listener dict {
    mode = 0600
    user = vmail
  }
}
service imap-login {
  inet_listener imap {
    port = 143
  }
  inet_listener imaps {
    port = 993
  }
  unix_listener imap-ipc {
    group = root
    mode = 0600
    user = $default_internal_user
  }
}
service imap-postlogin {
  executable = script-login /usr/libexec/nethserver/dovecot-postlogin
  user = $default_internal_user
}
service imap {
  executable = imap imap-postlogin
}
service lmtp {
  client_limit = 1
  unix_listener lmtp {
    group = vmail
    mode = 0660
    user = vmail
  }
  user = vmail
}
service managesieve {
  executable = managesieve sieve-postlogin
}
service pop3-postlogin {
  executable = script-login /usr/libexec/nethserver/dovecot-postlogin
  user = $default_internal_user
}
service pop3 {
  executable = pop3 pop3-postlogin
}
service sieve-postlogin {
  executable = script-login /usr/libexec/nethserver/dovecot-postlogin
  user = $default_internal_user
}
ssl_cert = </etc/pki/dovecot/certs/dovecot.pem
ssl_key = </etc/pki/dovecot/private/dovecot.pem
userdb {
  args = username_format=%Ln /etc/dovecot/imap.passwd
  driver = passwd-file
  override_fields = uid=988 gid=985 home=/var/lib/nethserver/vmail/%Ln
}
userdb {
  driver = passwd
  override_fields = uid=988 gid=985 home=/var/lib/nethserver/vmail/%u
  skip = found
}
protocol imap {
  mail_max_userip_connections = 12
  mail_plugins = " acl listescape fts fts_lucene imap_acl antispam"
}
protocol lmtp {
  mail_plugins = " acl listescape fts fts_lucene sieve"
}

I’ve imported a mailbox from MS Exchange. The problem is that after loggin into sogo it does not take existing special folders as for special use, for example:

doveadm -v -f table mailbox status -u john.doe@example.local "all" "Elementos enviados" 
 messages recent uidnext uidvalidity unseen highestmodseq vsize   guid                                   
Elementos enviados 26       26     41      223         0      1             1364340 be78a50b9c29de909962a85eea035b4b

(“Elementos enviados” stands for “Sent Items”). This is the folder coming from MS Exchange.

doveadm -v -f table mailbox status -u john.doe@example.local "all" "Sent" 
 messages recent uidnext uidvalidity unseen highestmodseq vsize guid                                         
Sent    0        0      1       1500932825  0      1             0     a761b121c06b7659bcb300001101a63a 

After user login, it create the Sent folder that it appears in SOGo as “Elementos enviados”

I’d want to imported “Elementos enviados” was regarded as “Sent folder” and not to get duplicated folders, how can I do that?

Thanks in advance!


(Michael Träumner) #2

Please have a look at your sogo.conf at     /* 20 Mail */

If you want to change the values do it with a custom template please.


(sb) #3

Thanks @m.traeumner I’ve configured accordingly:

sogod=service
    ActiveSync=enabled
    AdminUsers=admin
    Certificate=
    Dav=enabled
    DraftsFolder=Borradores
    MailAuxiliaryUserAccountsEnabled=YES
    Notifications=Appointment,EMail
    SOGoInternalSyncInterval=30
    SOGoMaximumPingInterval=3540
    SOGoMaximumSyncInterval=3540
    SOGoMaximumSyncResponseSize=2048
    SOGoMaximumSyncWindowSize=100
    SentFolder=Elementos enviados
    SxVMemLimit=512
    TrashFolder=Elementos eliminados
    VirtualHost=
    WOWatchDogRequestTimeout=60
    WOWorkersCount=10
    status=enabled

And:

sogo.conf has:

  /* 20 Mail */
    SOGoDraftsFolderName = "Borradores";
    SOGoSentFolderName = "Elementos enviados";
    SOGoTrashFolderName = "Elementos eliminados";
    SOGoJunkFolderName = "Junk";
    SOGoIMAPServer = "localhost";

However, I get:

“Elementos eliminados” (i.e. Trash) with the name “Enviados” (Sent)

Also, “Elementos enviados” is created in SOGo as a non-special folder.

Any ideas?

Thanks in advance!


(sb) #4

Well, I’ve found an ugly hack:

I’ve edited the file /usr/lib64/GNUstep/SOGo/MailerUI.SOGo/Resources/SpanishArgentina.lproj/Localizable.strings and restarted sogod, then it worked

HTH, if you know a better way of do it, please let me know

A.


(Michael Träumner) #5

I don’t have any other idea, I can’t explain why it isn’t working with settings at sogo.conf.

@stephdl Do you have any idea?


(Stéphane de Labrusse) #6

does sogod has been restarted


(sb) #7

Yes it did


(Michael Kicks) #8

Maybe i’m wrong but when i import data from a mailbox to another i move messages from imported folders to special ones.