Cannot install nethserver-mail-filter on ARM (requires rspamd >= 2.2)

NethServer Version: 7.7.1908 (final)
Module: nethserver-mail-filter (rspamd)

On a new install of NethServer on a raspberry pi4 I cannot install nethserver-mail-filter.
Requires: rspamd >= 2.2
Available: rspamd-1.9.4-2.1.ns7.armv7hl (nethserver-base)

Can you upgrade this rspamd to the required version for armv7hl?

Many thanks in advance!

I tried to download from:
and did:
yum localinstall rspamd-2.3-1.1.armv7hl.rpm
but it is missing a lot dependencies:

I have really no idea whether the above is the right way to a solution, or maybe completely wrong…
If it is the right way, maybe someone can point me to a solution how to get the dependencies?


@mark_nl I tried to compile rspamd using your rspamd.spec but failed. I added the needed cmake3 require in spec file but it still stops with following error:

line 31: fg: no job control


coming day’s i have a try to compile rspamd :grinning:

fingers crossed :crossed_fingers:


A heads-up,

was an easy fix, just needed to use the %cmake3 rpm-macro instead-of %cmake

we have a clean build of rspamd 2.4 which is still in testing for x86_64
Besides this much has changed in the 2.2-2.4 update cycle and therefore it still needs all the testing.

I’ll keep you posted

1 Like

I run 2.4 on my server without changes now, so it seems good for me

1 Like

first report;

on a fresh (updated) setup installed LDAP local accounts provider, nethserver-mail (without nethserver-mail-filter) and roundcube.

First the mail server did not work, mail kept stuck in the queue.
Found these error messages in the maillog:

... dovecot: lmtp(12757): Error: Corrupted SSL parameters file in state_dir: ssl-parameters.dat - disabling SSL 0
... dovecot: lmtp(12757): Error: Couldn't initialize SSL parameters, disabling SSL

After changing the TLS policy to Policy 2018-3-30 it worked. (did not dig in to this further)

Then installed nethserver-mail-filter with:
yum install --enablerepo=nethserver-testing nethserver-mail-filter

@installation found these in journalctl:

... rspamd[14103]: <qamb1r>; map; rspamd_map_dns_callback: cannot resolve query timed out
... rspamd[14103]: <fdp86m>; map; rspamd_map_dns_callback: cannot resolve query timed out
... rspamd[14103]: <dyatkr>; map; rspamd_map_dns_callback: cannot resolve query timed out
... rspamd[14103]: <qbq3yk>; map; rspamd_map_dns_callback: cannot resolve query timed out

nevertheless rspamd runs fine and mail is scaned by rspamd.

EDIT: installed (mail-filter) packages:


question (@stephdl) how can i check if rspamd actually blocks spam?

1 Like

Search for gtube and rspamd for testing

One example


Thanks for your work!
I tested on a raspi4b with remote AD and updated the running mail server with mail-filter.
There were no errors so far and gtube pattern is rejected correctly.

1 Like

Did some of the tests @stephdl suggested and rspamd did reject correctly over here too.
It runs for more then two days in a row without malfunction, memory leaks or other suspicious behavior.

However have one error in the log seen in the rspamd user interface:

call to (NEURAL_LEARN) failed (2): /usr/share/rspamd/plugins/neural.lua:517: attempt to index field 'ann' (a nil value); trace: [1]:{/usr/share/rspamd/plugins/neural.lua:517 - ann_push_task_result [Lua]}; [2]:{/usr/share/rspamd/plugins/neural.lua:1212 - [Lua]};

And one little quirk here, rspamd seems to start before an ntp the time is updated and with the lack of an RTC report to be running 50 years and 2 months. (ie since 1-1-1970)

IMHO we can release this and hunt down errors as we go because it is functioning and not crashing.


rspamd-2.4-1.1.ns7.armv7hl and olefy-1.1.0-1.ns7.armv7hl are uploaded to the arm-updates repository.
It may take a short while before all mirrors are synchronized, you will be able to update soon. :grinning:

aarch64 is on the test-bed as we speak and will follow within a few day’s.

If someone encounters quirks , errors in logs or problems please keep us posted so we can address them.