Cannot edit the self-signed certificate via Cockpit


I dit a fresh install of NS 7.7.1908 and cannot edit the sef-signed certificate.
Modifications you made are not changed in the certificate however the edit popup sreen shows the modifications you made.
I’ve also tried it on NS 7.6 and it gives the same result as with 7.7 a descriped above.



I could reproduce the issue. Thanks for your feedback.

Following errors are in /var/log/messages:

Oct 19 02:27:06 server2 remotectl: /usr/bin/chcon: can't apply partial context to unlabeled file ‘/etc/cockpit/ws-certs.d/99-nethserver.cert’
Oct 19 02:27:06 server2 remotectl: remotectl: couldn't change SELinux type context 'etc_t' for certificate: /etc/cockpit/ws-certs.d/99-nethserver.cert: Child process exited with code 1

Thanks for the report!

Issue filled:

@mrmarkuz the error on selinux can be ignored :slight_smile:

1 Like

NethServer Version: 7.7
Module: cert

When I try to update the fields of the self signed certificate, Cockpit disconnects.
If I revisit the edit page, my fields are already populated with the new content, but no new cert is issued.

Is it possible this is related to that I already have enabled LDAP/AD?
(I am willing to remove and re-add Samba, as I am early in deployment)

Guess what. It works from NethGUI, not from Cockpit (then Cockpit shows the change properly).

This is the expected behavior.

This is the reported bug, see the issue link above.


@Stephane_Schoubben the fix is ready to be tested! :slight_smile:
To install the package from testing:

yum --enablerepo=nethserver-testing update netherver-cockpit
1 Like

@giacomo the fix is working.
Thank you.