Cannot delete IP reservation

NethServer Version: 7.8.2003
Module: DHCP

I can create new IP reservations, and they successfully assign the specified IP address to the MAC address I provide. So far, so good.

However, I cannot delete an IP reservation that I no longer need. The three-dot menu at the end of the row has just one item, “Delete”. When I click that, a confirmation dialog appears, with “Cancel” and “Delete” buttons. The Cancel button works as expected, but the Delete button does nothing. The confirmation dialog remains on screen and the IP reservation is not deleted.

Any help would be much appreciated.

Are you using Cockpit (port 9090) or NethGUI (port 980)?

1 Like

You’re a genius! Well, you’re ahead of me anyway. I wan’t aware I had a choice, but I found that I was using port 9090/Cockpit. I connected to port 980/NethGUI and I was able to delete the reservation. Thanks for your help.

Calling @dev_team to look for a bug into Cockpit… DHCP Module.


Can you give us more informations? E.g. reservation name, ip, mac address

So we can try to reproduce the bug

@earthdog42 did the reservation name contained some special characters?

No, no special characters, the host name was “llanfairnantygof” and the IP address was I’m afraid the MAC address is now gone because I was able to delete the reservation using NethGUI (port 980). It worked though when the host was live so I’m confident the MAC address was valid.

I’ve realized since that the IP address I reserved was outside the range that the DHCP server is configured to assign (perhaps a mistake on my part). The DHCP server is configured to assign addresses from to and, as I said, the reservation was

Otherwise, this is a new implementation of NethServer, with no customizations.

You should be able to find an error in /var/log/messages around the time you tried to delete the reservation. Look for “dhcp”.

Nothing apparently connected to the deletion attempt appeared in the logs at that time. All I can see is the actuall deletion when I completed it using NethGUI (port 980).

It might be worth mentioning though that the host also had another, manually assigned, fixed IP address of, with the same host name (llanfairnantygof) configured in DNS. Might this be related to my problem?