Cannot administer Ejabbered through web admin

NethServer Version: NethServer release 7.3.1611 (Final)
Module: Ejabbered


I just installed the latest version. Everything OK except I cannot administer the jabber server. It just more or less shows an empty page. No virtualhosts.

As per instructions, group jabberadmins was created, user added to group.
Accessing “” only shows that there are no vhosts and no users online. Which seems to me to indicate that I don’t have full admin rights. (see: Adding or removing myself from “jabbaradmins” makes no differnce.

However the jabber server is working fine. So something is going wrong with the jabberadmins group not giving me admin rights.

Checked the ejabbered.cfg file under /etc/ejabbered/ejabbered.cfg.

% 10AdminUsers
{acl, admin, {user_regexp, “^($”}}.

As per:
I tried editing the file to see if I could it working by adding myself to the admin group like this:
{acl, admin, {user, “someone”, “”}}

However this results in ejabbered not working at all, neth webui says its up and running but nobody can connect.

Could it be that the group jabberadmins must be created by root?

Any help or pointers to what I can do to get this working is much appreciated.


I have tried and I have the same problem.
I also ran

db configuration setprop ejabberd WebAdmin enabled
signal-event nethserver-ejabberd-save
1 Like

me too. :confused:

And this jsxc 4 sogo has done me with it
(googe translator)

This is what I did (for a local LDAP provider):

  • yum install nethserver-directory
  • create jabberadmins group
  • add admin user to jabberadmins group
  • change admin password
  • install nethserver-ejabberd (if you already installed ejabberd, after configuring the group, execute signal-event nethserver-ejabberd-update)

Access the web admin console https://<serverip>:5280/admin, login with “admin@domain”

The web interface is almost empty, I don’t what should be there :smiley:

I don’t understand. Did you found any problem? How is it related to SOGo?


I’m getting the same result, I guess I was expecting this:

(from the nethserver documentation)

  • Messaging between users of the system
  • Possibility to divide the users into groups, according to the company or department / office
  • Chat server administration
  • Broadcast messages
  • Group chat
  • Offline messages
  • Transfer files over LAN

And the interface(admin console) at least doing this:

Administrators can:

  • Send broadcast messages
  • Check the status of connected users

But I guess none of that can be done via https://:5280/admin since as you say, it’s empty, it’s not even showing any users online although 5 are.

So maybe I’m just doing this the wrong way, the admin console does nothing and everything relies on configuration files and what the client supports.

I’ll just close that port for the time being as the webpage isn’t really showing anything. Not sure how to administer it. I guess I’ll just have to head over to the ejabbered web and check there.


You can administer it if you switch to admin in ejabberd.cfg
But that file gets overwritten.
And its not working as supposed to.
I also can’t see offline messages.