Cannot access samba server over VPN


I am using NethServer 7.8.2003 all updates installed. There is VPN Road Warrior setup on it.

There is another Linux server in my LAN. It runs Open Media Vault and serves as a samba server only.

There are three laptop computers (All Windows 10 Pro but all different versions of it).
There is a desktop computer (Windows 10 Pro latest version all updates installed).

Desktop computer is physically in a different location.
Laptop1 and Laptop2 are physically located in LAN but moves away.
Laptop3 is always physically away.

There is no problem for all computers if they are directly connected to LAN (either WiFi or using a network cable).

When using OpenVPN, Laptop1 and Laptop2 cannot access samba shares.

  • Laptop1 running Windows 10 2004 version. It does not display any error message. Always trying to display the share. I could not once wait for it to display an error.
  • Laptop2 running very early version of Windows 10. Displays an error saying semaphore timeout.

I cannot figure what is the problem. Since it happens only over VPN and VPN is on NethServer, I am asking in here to seek some advise.

Any help is appreciated.

Thanks & Regards,

1 Like

You have to add the VPN subnet as “trusted”.

1 Like

Would you elaborate that, please?

In cockpit servermanager go to System - Trusted networks. There add the subnet of your VPN network. The info in the admin manual is not very extensive.

It seems NethServer already handles trusted users. VPN subnet is already in the list.

I just figured that these computers having problems cannot do SSH to NethServer (

Other computers which does not have any problem can SSH to NethServer.

Moreover, computers having problems display below output

C:\Users\user>net view \\
53 system error.

Network path not found.

I am starting to think that problem is related with these computers and not with the setup.

Problem solved. OpenVPN has two client software available for download. One is part of commercial software or part of it, I think. Even it stays under commercial, it can be freely downloaded and used. Other client software is community built.


Community edition working just fine. Other client is giving me troubles I tried to explain so far.

Maybe it is related with their TAP drivers. I do not know. But, I am sticking with community edition.