Cannot access Samba IP from OpenVPN

openvpn

(Sergio Luiz) #1

NethServer Version: release 7.5.1804

Dears,
We have the Domain Controller setup on NethServer and OpenVpn Roadwarrior on Routed mode.

Everything works fine, except that OpenVpn connected clients cannot reach Only the DC IP address. All other ips and subnets are fine, just this IP is not working.

Theres anyway to make openvpn routed mode reach the DC ip?

Thanks!


(Davide Principi) #2

Hi @Miziara, thank you for reporting this!

As you describe, it seems a #bug. Can anybody reproduce it? /cc @dev_team @quality_team @support_team


(Markus Neuberger) #3

Hi @Miziara,

I could not reproduce. I tried on a server and on a fresh VM. I tried in gateway and server mode. I could ping the DC from the client in any case.
Do you use a router? Did you add a static route from it to the Nethserver?
I used Username, password and certificate as authentication mode. Which one do you use?
I tried with an Android client, which client do you use?
Are there errors in /var/log/openvpn/openvpn.log or in the clients logs?


(Sergio Luiz) #4

Hi @mrmarkuz, i appreciate your response.

We are using a NethServer as our only router. There are 2 wans (dhcp and ppp) on this server.
Im using OpenVPN Roadwarrior in Routed mode with Certificate only auth.
At advanced options, i have the full domain name, and in DNS the DC IP that i cannot access.

(Router 10.0.0.1, DC 10.0.0.3, Workstations 10.0.1.x (DHCP Server here), OpenVpn 10.100.0.x).
There are no static routes configured.
I tried on Windows 10 OpenVpn client and all ip addresses in the network are responding, just the DC ip doesnt.
No errors in any logs :frowning:


(Markus Neuberger) #5

I left these settings empty. You may give it a try…


(Davide Principi) #6

Did you look at /var/log/firewall.log too?