Cannot access internet over NethServer in VM

NethServer Version: 7.8.2003 (all updated installed)
Module: Gateway


I have a new NethServer running in a Bhyve VM under TrueNAS 12.0-RELEASE (former FreeNAS changing its name).

I have two nics assigned to it.
eth0 -> GREEN (Connected to my switch)
eth1 -> RED (Connected to my modem)

I have my eth1 (red) setup as PPPoE and it successfully connects to my modem and gets its dynamic ip from there (I am not assigned a fixed ip)

My eth0 (green) can be pinged from any client. Its ip is manually assigned and not changing.

NethServer does not have any problem reaching to the internet. I actually installed a new update on it.

However, I cannot have my client computers to reach internet over NethServer eth0 (green).

There is no firewall installed. Single item listed in applications view is Web server.

I have read a lot of posts here and none seems to be what I am facing. Actually, there is another system that I setup which is working just fine. It has static internet ip number and has firewall installed on it.

I wonder if I need to do something to turn on ip forwarding or something similar when firewall is missing.

I don’t think so. How are your clients configured? Static or dynamic IP?
They should have the IP of the green interface as gateway, for dns you should choose your internal dns-server. I think at your case also the IP of the green interface.

Problem turned out to be a DNS server problem.

I have another VM in my TrueNAS system. It runs Pi-hole. For a reason Pi-hole could not reach to the internet. (I am yet to investigate that).

Pi-hole VM is using same LAN interface as NethServer VM LAN interface. This may be related. I am not sure. I have another free nic in my system. Maybe I use it for Pi-hole to have all VMs run and working as I would like.

Once I switch to using DNS server (instead of Pi-hole) everything started to work.

Just try and error, also the pi-hole configuration can be the problem. I don’t have a pi-hole installation, but I think you have to give pi-hole an external DNS, if this is not reachable you should also have this problem. So I would advise to check the DNS-settings at the pi-hole server.