Cannot accept OpenVPN-Client config: validation.missing_wanpriority_rules

NethServer Version: 7.7.1908
There are two wans configured with “active backup” policy.
I have configured a OpenVPN-Client to another site, which works fine. But when I try to change something in this client configuration, I cannot accept the changes. The error is “validation.missing_wanpriority_rules”.
There is no difference whether I check the special wan sequence in the dialog or not.

Can somebody help here?

Are you able to select both WANs (each in one of the available dropdown selection boxes)?

Once set, Special WAN priorities seems to be unselectable (no real change in db). (/cc @giacomo )

A way to reset the WanPriorities for the vpn connection is from the Terminal (replace myclientvpn as appropriate):

db vpn setprop myclientvpn WanPriorities ''
1 Like

The but seems to be, that the rules are not unselectable.
Originally I had only one WAN, than I added another, and in the OpenVPN-Client settings only one of two interfaces were filled out and the “special WAN providers priority order” was checked. I was not able to uncheck it. When I have both interfaces filled out, I can accept the changes.

However, it should be possible to undcheck the check box.

Thanks @carsten,

a fix is ready for testing and should be released soon: