Can´t make work OCS (SSL error) SOLVED!

I have a week trying to make work the OCS and it rocks trought the web client but the agent gives me this error:

Starting OCS Inventory NG Agent on Monday, July 24, 2017 16:48:42.
AGENT => Running OCS Inventory NG Agent Version
AGENT => Using OCS Inventory NG FrameWork Version
AGENT => Loading plug-in(s)
DLL PLUGIN => Searching for Plug-in DLL(s) in folder <C:\Program Files (x86)\OCS Inventory Agent\plugins>
DLL PLUGIN => 0 DLL Plug-in(s) successfully loaded on 0 DLL(s) found
AGENT => Using network connection with Communication Server
COM PROVIDER => Loading Communication Provider <C:\Program Files (x86)\OCS Inventory Agent\ComHTTP.dll>
AGENT => Using Communication Provider Version <>
AGENT => Sending Prolog
DID_CHECK => Read DeviceID <001-PC-2017-07-18-16-52-26> and MACs <0A:00:27:00:00:0B00:24:E8:19:4D:A000:24:E8:19:4D:A0> in file <ocsinventory.dat>
COM SERVER => Initializing cURL library for sendRequest
COM SERVER => Using cURL with server authentication
COM SERVER => Disabling cURL proxy support
COM SERVER => Enabling cURL SSL server validation support using CA Bundle <NSRV.crt>
COM SERVER => Sending HTTP Post request to URL
WARNING *** COM SERVER => Failed to send HTTP Post request
COM SERVER => Cleaning cURL library
ERROR *** AGENT => Failed to send Prolog
AGENT => Unloading communication provider
AGENT => Unloading plug-in(s)
AGENT => Execution duration: 00:00:01.

I convert the NSRV.crt to NSRV.pem an locate inside the windows folder.

Don’t know what to do, Any one can help me.


It seems the client is trying to validate a self-signed certificate, but I never used it.

Check this one:

How to disable SSL for the ocs (db command) i`m bored with this is imposible to make it work.

I have tried all the howtos but the ssl errors always takes you to nowhere.

Thanks in advance.


I configure the agent with this options: (check this “ocsinventory” not “ocsreports”, and http not https)

Then Disable the cacert.pem (is a local network don’t need SSL)

It takes a while to upload the inventory but finally it works, thanks a lot giacomo


Would you mark your answer as solution please.

Hi m.traeumner,
But it cannot deploy