Can not connect with Samba shares after restore

v7

(NZs) #1

Could someone check the samba restore again? I did a test and the test computers can login but can not connect with the shares . I have to do a re-registering in domain. Thanks.


Disaster recovery failure revisited
(Davide Principi) #2

Can you see any related error message in /var/log/messages or /var/log/samba/log.*?


(Markus Neuberger) #3

I tested it now on a NethServer 7.4 VM with samba DC and a shared folder with read/write ACL for my testuser and it worked. The clients were a joined Win 7 and an unjoined Win 10. I did a disaster recovery, uploaded the backup file and it restored without problems. Both clients could connect to the share as testuser and create a file. On Win 7 I did not have to rejoin the domain.


(NZs) #4

First: thanks for response. I did a restore again and now the client computer can reconnect with share right after the config restore, sadly i do not know what was the problem first time. The only problem is at now: the files ACL rights are not restored with “Restores files” function. If the shared folder owned by domain admins (with normal unix rights), and the domain user have only read right (with ACL), only the domain admin have right after restore (it is restored) but the domain users can not connect with share. After resetting the ACL rights in Shared Folder they can connect, but I use samba with acl_xattr vfs object (Samba4 share cant change ACL of subdirectories with windows 7) and a lot of folder right fine tunings are missing. It would be very good if the ACL rights are backed and restored in backups too.


(Markus Neuberger) #5

You’re welcome. My shared folder ACLs (markus is allowed to read and write) were backuped and restored correctly.

So after restore these ACL settings are missing?

grafik


(NZs) #6

Yes, it is strange, because it is missing in the ACL, but the reset permission worked.

More info, maybe help, i did not do yum update after system restore, maybe a yum update helps?


(Markus Neuberger) #7

Yes, that may really help but maybe the shared folders ACLs are already missing in the backup.


(NZs) #8

Yes, the Shared folder’s ACL rigths are visible now (after a “yum update” and “restore files” again). Thank for help, only the files’ ACL rights backup/restore problem is not solved, but i think there will be solution if the new ACL functions will be active: Windows file server page