Bulk upload of new users not working

NethServer Version: 7.9
I am trying to upload new users via this command

/usr/share/doc/nethserver-sssd-rpm --query --qf "%{VERSION}" nethserver-sssd/scripts/import_users /home/admin/usertest.tsv

it executes but no new ursers are added.

Further is is possible to specify the Group?



Can I ask why you are putting in this effort into NS7 with an EOL on the horizon pls?


Number 1 i have only discovered NethServer.
Number 2 V8 is still being developed
Number 3 i only will install a new OPSYS if it is at least at V. 8.2
and it can be converted from V7 to V 8 …

If there are only a few users, it is easier to create them on the user interface after installing an account provider module on NethServer: either samba AD/DC (nethserver-dc) or openLDAP (nethserver-directory).
If many users, then you can create them by importing them after ONE of those account provider modules is installed.
For a remote AD account provider, the users must be managed from the main AD server (not from NethServer).

Hope this clears some doubts.

Thank you,
i have first installed the local AD/DC(nethserver-dc) working well

the problem is that the upload command is not working, i need to upload 100 users.
also why is there not an option to assign the group?

Many thanks


First import the users, then import the groups (optionally with users assigned to each one).

Do not know… maybe it didn’t recognize the file formatting.
The related log excerpts from /var/log/messages might tell us more about why it didn’t work.

EDIT: run the command as root.

I believe the example on the manual for importing groups has a typo (it says import_users instead of import_groups).

Thank you very much.

this is the error

i hope this clarifies the problem


Could not access usertest.tsv file.
Put the file under some of root user’s folder where it has permission access.

will do tomorrow, it is getting late here.
What about the group option?

Thank you very much


could not wait,

i tried as per screenshot

Please have a look

many thanks


import_groups groups.tsv

Where groups.tsv contains:

groupname <TAB> member1 <TAB> ... <TAB> memberN <NEWLINE>


jabberadmins josef mark 
administrators josef

Still cannot open file.

ls -lh userstest.tsv

Thank you very much for helping me.
i could not ms you yesterday as i run out of allowed messages.


1 Like

Not at all, you’re welcome.