Bug using the search field when creating Firewall rules


After creating hosts, host groups and CIDR subnets.

When I go in the Firewall Rules to create all the rules,
After clicking on create new rule, when selecting the source, I don’t have all the object, only 10 on 28.
So, I use the search field, but on the search result, all still “grey” and I can’t select nothing…

It’s a bug, isn’t it?

Even click on the button “page precedent”, the precedent page still “grey”… I must reload the page to return as normal…

Anyone can confirm or infirm this issue?

To reproduce the issue, you can made more than 10 firewall objects.
When creating a firewall rules, you can only select the 10 firsts.
And when using the search field…you can’t select a result!!!

It works for me.
I typed the first 3 chars of an object that was not on display, hit tab and the object appeared in the list, I clicked it and the view want back to the rule creation panel with the source field containing the object I chose.


damned… There’s something wrong on my prototype network!!!

Something or someone? :smiley_cat: (Just kidding)

Pfff… Something… :wink:

Log out and log back into NS…?

When I use the search as you do, ( ie: “hos”+tab ), it’s work.
The nethgui show all hosts and I can select.

But, when I enter “hos”+return, the netgui show me same result, but without the possibility to select anything!!!

You can easily imagine that I procede with the “return”… The “natural” way to confirm an action

1 Like

There’s room for improvement. :grinning:
My hopes are in @davidep. :smiley:

So it’s a bug or an issue? :ghost:

It depends on the reporter’s anger :blush:

1 Like



Want to bump this. Using return to confirm the search results in a gray overlay on the whole UI without the possiblity to click anything! Everthing is blocked by the overlay. Must refresh the page using F5 and loosing all configured settings.

Using IE11 on Windows Server 2012 R2


Uhm, I’m reproducing it. @jim which kind of browser are you using?

I’m using Safari and Firefox


We need to go deeper on this, @Jim @Hunv are you able to reproduce it? Which are the steps?

It’s pretty simple.

  1. Use IE
  2. Go to Firewall Rules
  3. Select a field where you have to search something
  4. Enter a string in the search-field and press return
    => Gray overlay. You cannot click on anything.


Doh! :scream:

1 Like

Its the default Browser on Windows. Usually you don’t install another browser on the Windows Server Platforms. So it is not just a theoretical problem.