Browsers keep complaining about certificate error

Hi,

While trying to fix a certificate issue (website not secure, open padlock) on my kids computer the browsers accessing outside websites keep complaining about the site(s) are not secure.

I checked the certificates (they ARE valid), date and time of my kids computer is correct and still all all browsers keep complaining that the website are not secure.

I am a bit confused. Anybody able to give me a heads up in some direction where to look please?

TIA

Generally the browsers can be induced to give a bit more detail about the problem, often with a button line “Advanced.” What’s the exact error?

I can not access the computer atm (remote) but the error is about invalid dates of the certificate, however looking at the details of the certificate, the dates are correct and the cert is valid.

Now from another angle, the computer is an old iMac 2007 with El Capitan (11.10). Googling around it seems MacOS can be picky about certificates, but the computer had no issues at all with websites for many months. Solutions presented are obviously about removing cert in keychain, set dat/time/reinstall browser (I tested Chrome and Safari, both throw the same error). Chrome is at version 110… and should be updated 113… but then again, Safari has the shows the same issue.

ps. The error also shows when accessing nethserver.org and typetuin.nl

don’t know if it could be related to this (although is old news):

Sounds like it could be an issue of the certificate chain being served. typetuin.nl serves the “long chain”, which I believe is still the default, but includes an expired intermediate CA cert.

Can you show me how I can find this please?

Does this mean that this expired cert, as a link in the chain, breaks the validity of the chain/cert (according to Safari/Chrome) and they throw the error?

If so, I would like to contact them (small family business) and educate them, BUT I need to be educated first :wink:

Thanks!

Thanks, I’ll check this too.

It seems El Capitan is ‘suddenly’ too old for today’s browser versions. I need to upgrade the CPU with a T9300/T9500 to be able to install Mojave (10.14).

Still strange that this happened all of a sudden for the machine worked perfectly for the last few months.

You know who to blame.
Cupertino Inc.

I don’t think Anyone is to blame.

Apple hardware do work for a long time (+10 years is NOT a rareity).

On the other hand: I can’t install any usable browser on Windows XP, which also worked for over 10+ years… Windows 7 still works, but getting difficult more & more…

Then again, who is wondering?
Someone trying to still use a ten year old hardware with a 6 years (since last update!) old OS?

These very old software and hardware should NOT be on the Internet at all!

And yes, I also have such old boxes still running, mostly as a VM, and only for certain duties, but NOT going on the Internet!!! These are available for archival purposes, nothing more!
I don’t expect to use these boxes for Internet, I don’t even allow them past my firewall…

My 2 cents
Andy

:slight_smile:

The oldie used as a typewriter to learn typing for an 11 year old. Unfortunately, all courses are online only today. So the actual demand and usage is very very very simple.

You’re still going on the internet with a risky and very outdated system, simply too old to use for education…

It’s like parents wanting to give their kids their old PC to use as a gaming box…
It’s just too dated and old, it was even new too slow to use for a gamer-box, but the parents don’t understand this… :slight_smile:

My 2 cents
Andy

I appreciate the concern, and I am fully aware. BUT then again, it is a stand alone system connected to a residential internet connection together with an up to date windows 11 laptop. It was my kid who warned me about the error and refused to proceed, it was ME forcing my kid to continue :slight_smile: :slight_smile:

And yes, I received ‘the look’ as in ‘you know beter then that!’

1 Like

You know what most people with a “residential Internet” think:

“Me? No, I have no data which could possibly interest a hacker…”

Most people don’t realize how correct they are!
The hackers “know” you’re a nobody, but they know you are paying for the stable broadband Internet connection, and using your Name! That’s enough to start a hack on a large governmental system, where you will be the hangman…

Too blind to see it coming, when Tyson is about to thump you with his fist!!!

My 2 cents
Andy

It was my kid who warned me about the error and refused to proceed, it was ME forcing my kid to continue :slight_smile: :slight_smile:

Dear LayLow,

you can’t learn early enough that visiting a brothel without the appropriate protective measures can definitely be fraught with certain risks. It’s similar to going online with outdated hardware or an outdated OS. And believe me…, as a former sailor, I know exactly what I’m talking about in this case. :grinning: :grinning:

Regards

Uwe

ok ok ok ok, got it!!! :slight_smile: :slight_smile:

Thanks for the worrying and tips, and you are absolutely right. So I ordered a T9300 CPU (15 EUR), will upgrade the 2007 iMac (which also serves as a TV) in the kids room) and install the latest supported Macos version.

BUT I still wonder why these issues popped up all of a sudden.

1 Like

Thanks! Yes, I saw that one too earlier, but did not give it too much attention. Maybe worthwhile for the iMac holds no data.

update: still need the CPU upgrade

https://lowendmac.com/2018/penryn-t9300-9500-cpu-upgrades-for-the-2007-imac/