Bootable USB doesn't show up / blackscreen after installation mode selected


I’m trying to install Nethserver on a dedicated hardware I just build.
I’ve downloaded the .iso here => Getting started with NethServer – NethServer

Unfortunately I encounter 2 issues :

  • If I write the .iso on my USB drive with DD, the USB drive doesn’t show up in the boot menu (and therefore, I can’t install it).

  • If I write the .iso with the “iso mode” from Rufus, the USB drive is showing up, and if I boot on it, I can see the very first installation menu with all the installation modes => Installation — NethServer 7 Final

However, it doesn’t matter which one I select, I have a black screen right after picking any of the option and nothing is happening.

Any idea how I can fix that ? Or is there any other way to install Nethserver ?

Thank you.

Hi and welcome.
Can you describe your hardware and settings (UEFI, secure boot…)? (some members here will suggest you to consider using some sort of great virtualization like proxmox)

You can try with Balena Etcher (or possibly even with Ventoy).
I did some tests in the past, althought the info is dated maybe some of it it is still valid:

1 Like

Thank you for the fast reply !

I’ve already tried Etcher, the USB drive doesn’t show up in the boot option from the bios (same when using DD).

I’ve just tried Ventoy, and I can see the usb drive and boot on it. But I have the black screen issue after selecting the instal mode (doesn’t matter which one I select - same issue with Rufus in iso mode).

I guess the black screen issue after selecting the install mode is the one that matter the most.
If I can fix that, I can install Nethserver.

The hardware is :

Intel Core i5-11400
Corsair Vengeance LPX 16Go (2x8Go)
Samsung 970 EVO Plus

I’m not sure about the “settings” you are asking for.
The secure boot seems to be disabled. And the UEFI is enabled (I’m assuming that’s the mode when you can use the mouse in the bios ?).

What would be the recommended options ?

I could be wrong but support for Rocket Lake CPU’s (and/or integrated 11th-gen GPUs) was added to Red Hat 8, so maybe it is not officially supported on CentOS 7 nor NethServer 7. Lets see if someone else has more info or knows if it can be bypassed with a kernel boot parameter or a new kernel.

Should work even if it’s not technically supported (should being the operative word here) I’d first start by going into bios and disabling secure boot I remember running into an issue were it caused problems in Linux booting from modern disk types like uefi

IMVHO UEFI should not be the issue at all for booting, because it landed on server far more years ago than desktop.
Moreover, UEFI (at least the first versions) is quite… stale on desktops too.

Hi @wedexej230

Today, I did an installation and I used balenaEtcher - Flash OS images to SD cards & USB drives for the creation of the USB key. All went OK.