Blocked nextcloud

nextcloud

(HF) #6

I guess that request is within NC itself. Please do not follow that advice. Use the software center or enforce via the console: yum update nethserver-nextcloud


#7

I usually only update through the Software Center. I hope I did nothing wrong while I was logged as admin.


#8

I get “No packages marked for update” but I still get this upgrade message:


(HF) #9

Ok, maybe your mirror has not been updated yet. But please use console for now, ignore this message you get.


#10

OK, I will wait. I the meantime, I cannot access my NC. But that’s not so important.
What is the present version of NC within NS?


(HF) #11

15.0.5


#12

Thank you all!


(Marc) #13

Do you have the latest version of the packages?

# rpm -q nextcloud nethserver-nextcloud
nextcloud-15.0.5-1.el7.noarch
nethserver-nextcloud-1.4.3-1.ns7.noarch

#14

Yes I do, same as you


(Marc) #15

This could be due to a partial upgrade. Logs shall provide some clues. By running occ upgrade command you’ll either finish the upgrade or get some errors showing the problem:

sudo -u apache scl enable rh-php71 -- php -dmemory_limit=512M /usr/share/nextcloud/occ upgrade

#16

Thanks a lot, that solved the situation!


#17

In fact, sync works again, but I cannot get the web interface


#18

I have HTTP ERROR 500


(Marc) #19

Did you spot any error in the logs or the command line? Related to an app?
Is the httpd service running?


#20

No error while updating, httpd is active and running.
Where is the NC log file?


(Marc) #21

IIRC it’s under /var/lib/nethserver/nextcloud/ directory


#22

Nothing special in the log. I keep on searching.
Thank you


(Marc) #23

Yoy can try to disable nextcloud apps or take a look in browser console for any clue


(Michael Träumner) #24

@loic You edited the headline to solved. Would you say us, what was your solution and mark this answer please as solution.


#25

How can I disable NC? I have no access to its interface