Bind connection Zentyal AD server error

NethServer Version: 7.6.1810
Module: LDAP

Hello, everyone, I’d like to describe my current configuration:

Zentyal v 6.0.1 domain server with several PC-Servers- and connected users
domino name= maui.lan
host name= maui-srvdc
administrator user
ldapuser user ( with administrator rights ) _
various domain users
192.168.1.*** network

Nethserver mail server v 7.6.1810
installed modules email - webtop - POP3 connector
domain= mauitech.eu
server name= posta.mauitech.eu
192.168.1.*** network

I configure the connection " active directory - join to a domain " to the domain server Zentyal maui-srvdc.maui.lan, I provide the credentials of the server DC Zentyal using the user administrator, the join was a successful. Users are uploaded from the DC Zentyal to the nethserver mail server, and the mail server is added to the machines seen by the domain controller. _

I am asked for credentials for ldap applications and I provide the same administrator credentials provided for the joint, but nethserver returns me an error of “incorrect LDAP credentials”.

_


_

Other tests carried out

Created another user with administrator rights in the domain server, but when I use it for bind I get the same error from nethserver.
Tried both with STARTLS set to ON and OFF with the same error result.
Finally I tried to use a test server, domain microsoft server 2016
name domino= be****.local**
host name= serve*****
administrator user
nethserver performs the BIND correctly.

How can I solve the problem of BIND authentication with the domain controller Zentyal.
Thank you

Hi @deltav-1 and welcome to the NethServer forums. I am glad you have found our community and started actively with posting your support question. As always, we are here to help!
Just a small point of general use of these forums: Since NethServer is a global community, the policy is English only in these forums. To be able to help you better it is important that every member of this forum is able read and understand your post. If your English is not good enough, please use a tranlastion service like Deepl.com/translate or Google translate.

@support_team can we help our new community member with his issue?

I took the liberty to translate it for you using Deepl.com/translate:

Hello, everyone, I’d like to describe my current configuration:

Zentyal v 6.0.1 domain server with several PC-Servers- and connected users
domino name= maui.lan
host name= maui-srvdc
administrator user
ldapuser user ( with administrator rights ) _
various domain users
192.168.1.*** network

Nethserver mail server v 7.6.1810
installed modules email - webtop - POP3 connector
domain= mauitech.eu
server name= posta.mauitech.eu
192.168.1.*** network

I configure the connection " active directory - join to a domain " to the domain server Zentyal maui-srvdc.maui.lan, I provide the credentials of the server DC Zentyal using the user administrator, the join is successful. Users are uploaded from the DC Zentyal to the nethserver mail server, and the mail server is added to the machines seen by the domain controller. _

I am asked for credentials for ldap applications and I provide the same administrator credentials provided for the joint, but nethserver returns me an error of “incorrect LDAP credentials”.

_
Bind_error
Bind_error.PNG442×571 10.8 KB
_

Other tests carried out

  • Created another user with administrator rights in the domain server, but when I use it for bind I get the same error from nethserver.
  • Tried both with STARTLS set to ON and OFF with the same error result.
  • Finally I tried to use a test server, domain microsoft server 2016
    name domino= be****.local**
    host name= serve*****
    administrator user
    nethserver performs the BIND correctly.

How can I solve the problem of BIND authentication with the domain controller Zentyal.
Thank you

Translated with www.DeepL.com/Translator

thank for your suggest… Ill use english languages in a future
By

1 Like

Try with administrator@maui.lan

As stated in the manual, use a dedicated account with non-expiring password instead!

http://docs.nethserver.org/en/v7/accounts.html#join-an-existing-active-directory-domain

2 Likes

tried doesn’t work same error and also tried with dedicated new user with administrator rights

Perfect it working I forgot @
Thank

2 Likes