Best Way of Updating PHP... or not


#1

Hello. I’ve installed Nethserver for the first time and installed OwnCloud as well. In the OwnCloud Admin page, this message shows up:

Your PHP version is outdated. We strongly recommend to update to 5.3.8 or newer because older versions are known to be broken. It is possible that this installation is not working correctly.

Reading up on the discussion boards I’ve discovered that both the OwnCloud and PHP packages are a little bit dated. I’m not so worried about OwnCloud but this PHP message bothers me.

  1. Should I worry/care about this “oudated PHP” message? If so,
  2. What is the best way of upgrading PHP and which version should I upgrade to?

I’ve read about nethserver-php-scl but I’m hesitant to use it as it’s (apparently) beta software and the server I’m running needs to be (relatively) stable.

Thanks in advance!


Should I be worry about thoses security holes from Apache, PHP and SSL
(Stefano) #2

you can safely ignore that message

PHP (and all packages) is mantained by RH that backports bug fixes…

the problem is that you may lack some features if you decide to use some webapps that want/need more recent version (i.e. Joomla)

IMVHO, a webapp that need a bleeding edge version of php should be avoided… I won’t put on my server (exposed to wan) something that has not been reviewed enough.
my 2€c


(Jonathan Dumont) #3

Hi Stefano;

So by your comment should I also not being worried about the Piwik warning ?

Warning Piwik will stop supporting this PHP version in May 2015. Upgrade your PHP version before it’s too late! The PHP version 5.3 you are using has reached its End of Life (EOL). You are strongly urged to upgrade to a current version, as using this version may expose you to security vulnerabilities and bugs that have been fixed in more recent versions of PHP.

I found this as reference : https://wiki.php.net/rfc/php53eol