Backup setting for server

backup

(Bill ) #1

I’m having trouble getting automatic backups working. I created a backup location on a freenas server but it always fails. windows sees the network share as \FREENAS\Backup. permissions are set so even guests have full access. Any ideas what might be wrong?

==== Report for data backup =====

Backup started at 2017-06-12 12:05:04
Pre backup scripts status: ERROR

Extract from log file /var/log/backup-data.log:

2017-06-12 12:05:04 - START - Backup data started
2017-06-12 12:07:12 - ERROR - Error while mounting 192.168.1.10:/Backup : mount.nfs: Connection timed out
2017-06-12 12:07:12 - ERROR - Event pre-backup-data failed - 1


#2

Use only the ip for the Server.


(Bill ) #3

On the Nethserver setup page under NFS there is a host and a share text box. I assume the IP address goes under host and the share should be the path to the shared folder on that host. Just entering the ip address generates an error.


#4

Sorry, I said server… thinking cifs, instead of host.
Should be only the freenas ip in the host box.
Then share path in the share box.
Make sure your Nethserver node is permissioned or allowed in Freenas.


(Bill ) #5

With the host ip and path /Backup it still fails so it must be a permissions error. There is nowhere to enter a user name and password in the nethserver backup configuration setup so I don’t know how I’m supposed to get nethserver to login to the freenas share. confused??


#6

We need the failure logs to determine if it’s a path / mounting issue or a write permissions issue.

Using nfs, you need to “tell” freenas it’s ok for nethserver to write to the share.

Are you sure your trying to connect to freenas using nfs or is freenas setup for cifs?

You could post a screenshot of your shares setup from freenas.