Backup over SFTP

NethServer Version: 7.9.2009
Module: Backup

Good Morning everyone.
i try to confiure the integrated Data-Backup on a NAS with sftp. i can get a connection with a normal client like winscp. but if i try to initiate the connection over cockpit and finish with check it, i got always a configuration failure. i also did not find a log or something for that. is there somethin i miss?

Probably the sftp implementation of your NAS (would you please share which is?) is not “good enough” to comply Nethserver. Someone is having problems also with WebDAV.

i dont think that is the problem. it is an synolgy nas

Some of the issues with the SFTP protocol are reported here.

And an experience of connecting NethServer and a Synology box with some issues.

Hoping that these experiences can help you, i would like to suggest to have a test with WinSCP:

  • connect
  • create a directory
  • create a file into the directory
  • create a sub-directory into the previous directory

and tell us if something of these operations fails.

1 Like

thank you, i read some of the experiences of others, but not all. i did the test over winscp how you described it, worked like a charm.

Ok, this should allow correct use of sftp implementation, as far as i know.
Looking through the links I provided you, can you find the right command on shell (NethServer) for identify the error?

1 Like

nethserver-backup needs to be able to ssh into the server before initiating the SFTP connection. In a way it’s more SFTP over SSH than pure SFTP.


hmm… it needs former to do ssh? you mean i had to open ssh from the wan side?

When configuring the backup task, it connects to the storage through SSH to perform a variety of tasks (controlling rights, sending a specific public key for authentication, …). See the thread :

1 Like

puh, did not find a solution… cringe that a backup is so complicated.

@robb suggested to use

Didn’t tried yet.

1 Like

@capote tried it and it did’nt work :frowning:

Unfortunately not. I have not found a affordable cloud provider that supports “smart” SFTP for Nethserver Backup.

Some webhosting packages include SSH access but they are expensive as regards storage.

What about using a cheap VPS as SFTP backup storage? Install a CentOS 7 and NethServer (or any other supported distro), setup SSH and the SSH/SFTP cloud storage is ready.

Best price storage VPS I found is time4vps.

I use contabo, they offer storage VPS too.

Hi Markus,
this is my used way for the first backup.
But I want to use a second backup, because one backup is no backup.
And for that, 1 TB - offers for 50ct/month in the first and 5 €/month in the second year were very tempting.

Your time4vps-Offer is fascinating, beacuse really cheap and located in the EU. I will try it.

Thank you, marko


time4vps. doesn’t support custom ISO…no Nethserver install. No trial period, but 30 days refund guarantee.

It supports CentOS 7 OS, you can install Neth on CentOS7 without need of an ISO.

1 Like

I tried it… a lot of errors. I will start a new thread.

1 Like

hello again,i am still trying to make the backup of the data via restic and sftp possible. after i now created the backup via the console, completely according to the instructions, it was possible to get one step further. I see after finishing the preparation how the backup tries to access the SFTP drive, but the password transfer does not work. Although the correct password is stored, which I then entered again during the query via the console, the SFTP system shows that the user information is incorrect. Unfortunately, I now also have no access via Cockpit, because there is only a circling animation to see, it is unfortunately not given access to the menu. Does anyone perhaps have an idea how to solve it and why the combination of username and password does not work?

I was looking for a problem I had with SFTP and backup and came to this post.

I have now solved the problem

The error I solved was that SFTP Directory must have the full address of the directory and also make sure that the directory really had rights to write in the directory.

Do not know if it helps but still want to give my solution to the problem.

1 Like