Backup Inclusion not working

backup
v7

(Shiena) #1

NethServer Version: NethServer release 7.6.1810 (final)

I followed this instruction here http://docs.nethserver.org/en/v7/backup.html#inclusion to include /opt and /etc in our daily backup.
image

But when I was doing a test restoration, the /opt and /etc locations are not showing on the hierarchy.
image

Even tried to do a manual restore via putty, but same result.

Does the inclusion path needs to be under /etc/, for example /etc/postfix/ for the backup inclusion to work?
And I don’t need to issue any signal-event or expand-template command after modifying the custom.include file?

Thanks


(Markus Neuberger) #2

There may be a missing or too many line breaks in the custom include file.

From the docs:

Make sure not to leave empty lines inside edited files.

Missing line break:


(Shiena) #3

Hello MrMarkuz,

My custom.include looks like this now when I issue cat:
image

and mcedit looks like this:
image

I checked the restore files which does not show /opt and /etc folders and the other sub-folders for some reason even before modifying the custom.include file:
image

But it works on test manual restore via putty:

Thanks for your help.