Backup hdd not showing up in backup options

I’ve got a 4tb HDD to backup my nethserver.

I had it configured and working well but we had an electrician around to test the circuit breakers, unfortunately I didn’t have my server plugged in to the ups.

When I booted it back up the Raspberry Pi was trying to boot from the backup drive instead of the nethserver SSD (if I unplugged it and rebooted it worked fine but if I plugged it in again it would get reassigned and cause the Raspberry Pi to crash).

I decided I would fix it the next week (and completely forgot about until I tried to restore a backup).

So Ive fixed the mounting and set fstab correctly on reboot the drive shows up in the storage part of settings on cockpit Im able to erase and remount in via nethgui or cli (ive got it mounted to /mnt/backup) I can write to it and on reboot it mounts fine and is still writable.

Problem is when I go to set the backup again nothing shows in the devices

@Shane_Treweek… no commas or carriages return in your message. Would you please kindly… edit your message and add a bit more info?

What your RasPi sais if you plug the disk?
Receives any mountpoint?
Which is the filesystem?
Did you check that the content is browseable from another installation (depending on the FS)

Sorry for that I was quite tired when I typed that (need to remember to check before posting :pensive:) apon re-reading my post I couldn’t fully understand what I wrote :grimacing: so i started the post again.

It works fine now (mounting and on boot no conflicts)

it’s mounted automaticaly at /mnt/backup

it’s formatted to EXT4

yes I booted a live cd (well usb) ubuntu on my mac plugged the drive in and was able to write to the hdd

also I’ve it helps

# ls -l /mnt/backup
total 16
drwxrwxrwx 2 root root 16384 Sep  3 22:24 lost+found

and on creating test txt

# ls -l /mnt/backup
total 20
drwxrwxrwx 2 root root 16384 Sep  3 22:24 lost+found
-rw-r--r-- 1 root root     8 Sep  4 10:06 test.txt

and incase my fstab isn’t correct this is what I have in /etc/fstab seems right but mabe it’s not

 # cat /etc/fstab
UUID=7532-D82F  /boot vfat    defaults 0 0
UUID=ca8fff13-d3c1-4c6b-8367-563660e0de35 / ext4    defaults,noatime 0 1
UUID=70a6f1cc-640a-478e-8821-7257f2c348f3 /mnt/backup auto defaults,noatime,nofail 0 2

I origonaly had ext4 in the last line
UUID=70a6f1cc-640a-478e-8821-7257f2c348f3 /mnt/backup ext4 auto defaults,noatime,nofail 0 2
but when I ran
mount -a it would give an error about config not being correct

This seems to be the problem.
After removing the mount point by setting it to default in server manager I was able to select the drive for backup.


turns out the issue was I had the drive mounted when I removed the mount point and restarted the server it showed up

1 Like