Authenticating with domain credentials issue


I recently joined my storage appliance to the Samba AD. Using the domain credentials, I’m able to mount my smb shares on Windows, Mac(GUI) only.
On Linux and Mac cli I always get: mount error(5) Input/output error.
I use:
mount -t cifs -o username=username,domain=my_sub_domain,password=password //server /local
The logs on the storage are showing access denied.
Any advice would be much appreciated.

Thank you

Hi @sergiu.oanes,

welcome to Nethserver Community!

What if you try without domain or full domain name?

Found some older threads with similar error in combination with a NAS:

Maybe it’s about the password?

nope, it doesn’t work. I also tried different sec options with no result. Although, I’m able to mount it if I use a workgroup user from the storage appliance. The issue is only when I’m using domain credentials. Not sure what else I could try.

On my NS this works:

mount -t cifs -o user=domain\user,password=xxxx //IP/share /mnt/ (domain without .tld!)

not working :frowning: …thanks though

Did you also try the vers=2.1 (or other version of smb) option?

yes, I tried vers=3.0, 2.1…same thing.