Asterisk 13 and FreePBX 14 on NethServer 7

It seems like your local service providers cache has not synced yet. I had the same issue with mine. Our local cache is maintained by tenet in South africa. But i got them to do a forced update, It seems that none of your local caches have updated yet.
Give it about 24 to 48 hours to update.

Regards

Clinton

Thanks for the feedback. I will give a try this weekend.

Idont want to brag or anything. Sorry, but except for the freepbx still in beta and alot of the features of the usual freepbx are still missing. Not Nethservers fault. Its looking good.

Only one thing @jobezic that I have found.
amportal when i run comands periodically brings bring up an error of using php 5.4.1. And it requires a minimum of 5.6. Im just trying to replicate and get a screen shot. I will send it through later

So far 20 extensions 1 sip trunk 1 iax interbranch link to an exsisting box and a fax link to my offices hylafaxsystem proudly running on Nethserver. And only one problem… It still wont make my cup of coffee… otherwise its looking really good

Regards
Clinton

You have to install FreePBX modules from “modules admin” page.

PHP version used by apply changes should be already fixed, isn’t it @edoardo_spadoni? Which command give you thhis error?

1 Like

Try to run your amportal or fwconsole inside the scl environment:

/usr/bin/scl enable rh-php56 'amportal'

1 Like

Just noticed you’re working hard with FreePBX guys :slight_smile:

2 Likes

@lorentedford @Shadowfire @Adam @advcorp @chrisg @Nas @compsos are you interested to help us out with Asterisk and FreePBX? New rpms are ready!

3 Likes

Thanks @Stll0 Im feeling a bit dumb right now. It seems thevsouth african cache had not pulled everything. Or maybe its just me. Im not seeing the usual, ivrs or conference rooms, im still in freepbx 12.
Regarding the error, I will send a screen shot and the full commands sent.

Ill try the scl enviroment as soon as i get back

A post was split to a new topic: Errore during Bandwidthd installation

3 posts were split to a new topic: Failed to run installation FreePBX scripts

I have had a couple of Sipgate accounts that I have been using for a couple of years and have been recently thinking about incorporating them as trunks into Asterisk, I am interested in the progress of Asterisk / FreePBX usage within NS7.

1 Like

Good to know! Please test it and let us know your feelings or issues.

1 Like

Hi brilliant people.

I am trying to install FreePBX on a fresh Nethserver 7 beta 2 server, but am getting package conflicts errors. If I skip these conflicts, Asterisk does not install at all:

—> Package libfontenc.x86_64 0:1.1.2-3.el7 will be installed
–> Processing Conflict: asterisk13-voicemail-13.9.1-1.17.sng.x86_64 conflicts asterisk13-voicemail-odbcstorage
–> Processing Conflict: asterisk13-voicemail-odbcstorage-13.9.1-1.17.sng.x86_64 conflicts asterisk13-voicemail-filestorage
–> Finished Dependency Resolution
Error: asterisk13-voicemail conflicts with asterisk13-voicemail-odbcstorage-13.9.1-1.17.sng.x86_64
Error: asterisk13-voicemail-odbcstorage conflicts with asterisk13-voicemail-13.9.1-1.17.sng.x86_64
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Any ideas?

You’re right, I can reproduce the issue. I still don’t get why it happens, but for now you can workaround the problem installing with command

yum --enablerepo=nethserver-testing install asterisk13-voicemail-odbcstorage nethserver-freepbx

instead of yum --enablerepo=nethserver-testing install nethserver-freepbx

3 Likes

Hi Stefano. That solved the problem :smile: Thank you for your quick response… now I am off to test!

Ciao

2 Likes

Hi,
I’ve finally came around to test freepbx on nethserver 7 but the installation process hangs after the “Setting permissions” part - I’ve used the commands above posted by Stefano. Freepbx seems to be partially installed - i see the modules on NS GUI - but the services are not running (they can be launch manually) and it is not possible to access the web interface of freepbx.
I’m testing it on a NS7 b2, installed from rpm on a kimi (OVH) dedicated server. For testing pruposes, almost all modules are enabled and I’ve further installed fail2ban.
Any ideas what is causing the installation to hang? I remember it took quite some time for the post-installation scripts to run but after a couple hours I rendered to the fact that it was indeed hang.

Hi @Fred,
I’m trying to figure it out right now.
workaround:
stop installation with ctrl+c and launch signal-event nethserver-freepbx-update

1 Like

Woks like a charm. Thanks!
I Look forward to give it a go and report back.

edit: @Stll0 uff, when i first logon it tells me I have 14 tampered files!!!
running fwconsole ma refreshsignatures I get the following error:
"Updating Hooks…PHP Fatal error: Can’t use method return value in write context in /var/www/html/freepbx/admin/modules/userman/functions.inc/auth/modules/Msad.php on line 600"
When i run fwconsole chown gives me the same error.
Any ideas?

edit 2: Whatever i do i get that error. I’ve tried uninstalling ucp, so i could reinstall userman, but the same error shows up…

1 Like

Hi guys, sorry im without internet and so limited to access. I should up and running by tuesday next weeek. I will be back then sorry.