Assistance wtih setting up Matterbridge in Nextcloud to use Nethserver ejabberd

NethServer Version: 7.9.2009
ejabberd: 1.8.4 (as of April 23, 2021)
** Nextcloud** 20.0.9 (as of April 23, 2021)

Hello @support_team,

I’m interested in bridging my ejabberd with my Nextcloud Talk. We use ejabberd in our Webtop App and I’m hoping to rollout Talk (in Nextcloud) to other employees in our office that do not use mail (do not have access to Webtop). I’d like to have both groups of users still be able to send/receive messages between buildings.

I have installed Nextcloud and ejabberd on my Nethserver. In Nextcloud I’ve installed matterbridge and I’ve selected the XMPP/Jabber option in Matterbridge from with Nextcloud Talk. I have questions about how to fill in the fields for XMPP/Jabber in Matterbridge. Nothing I try is working:

XMPP/Jabber server URL:
Question #1:
I’ve tried https://localhost:5222 and I’ve tried a domain URL I’ve created in my HAProxy that points to my nethserver IP. Should I use localhost with the port 5222 since my Nextcloud and ejabberd live on the same (Nethserver) server?

Question #2:
Whichever URL I try I receive an error in the matterbridge log that sayd that I have too many colons in my URL? Any idea on how to get around this error? Maybe I shouldn’t use this GUI and I need to add the URL to the config file itself? Any ideas where the matterbridge config file lives on Nethserver > Nextcloud?

MUC server URL:
Question # 3:
Do I need to add this URL?

Channel:
Question #4:
What is the default channel name setup in ejjaberd on Nethserver? I didn’t create a channel so perhaps ejabberd creates one automaticaly? Do I need to have a channel listed in Matterbridge?

Any help that can be provided will hopefully help others with this setup and would be greatly appreciated by me!

Thank you.

Here are the settings I used:

image

Unfortunately not. I need to add a line to skip tls cert verify.

Yes, you need to because a room is needed and the MUC server provides the rooms.

There’s no default room and I assume you need a channel/room like with other apps supported by matterbridge.

To create a room:

/opt/ejabberd-20.03/bin/ejabberdctl create_room testroom conference.domain.local domain.local

Users can enter a room via the jabber client. You can view the rooms in ejabberd web admin.

To be continued…

2 Likes

Hello @mrmarkuz,

Thank you for taking the time to look into my question!

Regarding the channel…I use ejabberd as my chat client in Webtop. I’m trying to have my Nextcloud Talk connect to ejabberd so staff that use Webtop chat can also converse with Nextcloud Talk. Where can I check for the name of the channel that is used in ejabberd for Webtop Talk? I’m hesitant to create a channel in ejabberd and break my chat app in Webtop. Or do I create a channel in ejabberd (as you’ve instructed) and I update my Webtop to use that channel?

Thank you.

Hello @mrmarkuz,

I’m finally ready to create my new room. I had to use the ejabberd admin to help me determine the name of the ejabberd hostname to use in the create_room instruction. But it appears I now have a room. I’ve even confirmed that this new room can be used by my Webtop Users (updating Webtop Admin Properties).

I’ve updated my Mattermost config in the GUI with my new room/channel. But I’m now seeing a certificate error which I think you also had an issue with.

I’ve used this find command to help me find the .toml files on my Nethserver:

find / -type f -name “.toml

This pointed me to .toml files in /tmp folder. I then searched the github mattermost.toml sample and could see a command for ignoring certificate:

SkipTLSVerify=true

But when I tried to edit the toml file on my nethserver…as soon as I run the matterbridge service or save my settings in matterbridge on Nextcloud my .toml file is overwritten and the SkipTLSVerify=true setting is removed.

Any ideas on how we can skip the certificate check and not overwrite this file?

Thank you.

1 Like