ARM development: next steps

Will do so …
Upfront: has PERL some (environment) variables which could be use full ?.. (like pseudo-code $ARCH)

Oke, at least I tried :grin:

1 Like

I’ve found this:
But I don’t know if it is really good, I’d go with a simple file check

1 Like

the WARING part is alarming.

Small code-style question, do you want me to comment “arm specific code” or not ?

I’d say only if the code is not self-explanatory. Probably in this case it could be useful to have it.

1 Like

Modifications for Squid and OpenVPN are ready to be tested.
I also know that @Amygos did some good analysis on the Raspberry image and he found that Dedalo (Hotspot) works well!
He also pointed out another library path problem:

I think the fix can be the same of other cases.

Really thank you for the excellent work!

It’s holiday time here in Italy, I will be back on work January 7, but I will try to respond to any question during these couple of weeks!


hi all

I need some help

I do not have (yet) the hardware to test this on aarch64, please can you help here to verify the issues

others architectures are verified

1 Like

You can use a KVM machine for that: yum install qemu-system-aarch64
Download the aarch iso from CentOS mirror:

Make sure to select aarch64 when creating the VM.
During install you will have time for a trip abroad: it’s very slow!


Thanx, will test it on aarch64 this affternoon

1 Like

I would like to test a couple of issues inside an aarch64 machine, so I’ve created a new scaleway account.

But when creating a new machine, there is no CentOS image available for ARM.
What are the steps to have a running CentOS/NethServer aarch64 machine on Scaleway? Do I need to create my image?

Tested on virtual machine using qemu. Everything good.
Thank you @mark_nl!

1 Like

i’m just playing a little with some ns76 altarch to see where we are, because i was a litle absent during last two months… anyway, i think that Ultimate ns7 software updates origin policy break yum on altarch
error on software center:
failure: repodata/repomd.xml from ce-base: [Errno 256] No more mirrors to try. [Errno 14] HTTP Error 404 - Not Found

it seems that did not handle correctly with altarch, ie if the ce-base seems to redirect to
but there is no such url

to make it work i have disabled from ce-* mirrorlist and changed baseurl, ie:

and i think we should also disable some repo for altarch:
ce-sclo* for armhfp
ce-sclo-sclo for aarch64

someone else had the same problem?


Thanks for reporting, we will look into it!

1 Like

Seems like @Mr.Olie had the same problem:


Just pushed a fix to, would you mind checking it out?


Just did a quick test using curl, seems good:

curl ''
curl ''

it seems ok to me, for aarch64 and armhfp. tnx!

ops… i talked too early… i’ve done a full update, but now i got error on sclo which didn’t exist for aarch64

more tests, later…

1 Like

Please give me the official URLs [or open a PR for them]!

This is from nethserver repo file:



Disabled it manually, like @dz00te said.

sorry I do not think I understood :thinking:
the problem is that ther is no official url… i mean if you check a mirrror:
only sclo-rh exixst for aarch64, while for armhfp there is no sclo* at all

i don’t know if it’s possible to manage this from mirrorlist (that will be probably the best solution), otherwise the only solution i see is to change
check the arch and and enable/disable [ce-sclo-sclo]
and [ce-sclo-rh] depending on the arch… but probably i miss something… :sweat_smile:

1 Like

Yes, I forgot that …it’s the kind of input I need :smile:

IIRC packages that we recompile from EPEL and SCLo as dependencies for our modules will go to nethserver-updates/armhfp. Wherever an upstream mirror exists, mirrorlist will point to it.

Otherwise it could point to an empty/dummy repo and its packages are expected to be in nethserver-updates (or nethserver-base).