Append legal note to Mails not working

Hi,
today I installed a module of Nethserver I didn’t used before: Mailserver.
I support a company in IT and they need a mailserver because their current provider, an ISP, don’t has the option to automatically add legal notes to all send mails.
I was happy do find this option in Nethserver assuming that it will work for all E-Mails that are send by this mailserver (via Roundcube, via Outlook/MailClients, via Smartphones etc.).
After I setup the Mailserver including only the Roundcube module (what are the others??? There is nowhere an explanation!), I configured the two domains we will use.
I activated the Checkbox “Append a legal note to sent messages” and entered a test-text.

After that I set the admin-password and added a new user for testing.
I logged in with that user on Roundcube and send a Mail to my personal address. I received it but without signature.
Are there any other dependencies or is it a bug?

SOGo groupware from Software Center -> NethForge (NS 7b1), Software Center -> Available (NS 6.8) and/or WebTop groupware from Software center -> Available (NS 6.8, NS 7b1).

Not the original topic of the thread but I think this don’t tell me what the function is:

You 're right!
I use NS 6.8 as multi domain email server and I have selected all (all of them are easy to guess).

Not for me.
I only know ClamAV but not what the other clamav-modules are. But even that is something not everybody might know.

2 Likes

Yes, I think that must be more documented.

Anyway, on NS 7b1 are less options:

@davidep can you take a look? Is there anything to check?

Thanks for the reminder, I’m putting it on my TODO list!

2 Likes

The current Roundcube configuration seems to use Postfix maildrop to send messages. I think it should send through SMTP port 587. Therefore the disclaimer feature cannot work with the current Roundcube configuration.

Could you check other email clients too?

Please, note that disclaimer is triggered when the message sender matches the domain of the disclaimer.

As temporary fix you could also try to tweak /etc/roundcubemail/config.inc.php. On line 199, replace 25 with 587.

 $config['smtp_port'] = 587;

Edit: also set on line 195

 $config['smtp_server'] = '127.0.0.1';
3 Likes

OK, thanks! I will check it.

Let us know, I’d like to mark it as solved :slight_smile:

Works! :clap:

2 Likes

I think we should open a bug on 6.8 and 7.

What do you think @davidep?

2 Likes

Bug opened

3 Likes

Ready for test!

2 Likes

Hi, what is the command to install the fix (on 6.8)?

1 Like

Hi,
Is for v7: nethserver-roundcubemail-1.2.1-1.ns7

Sorry @Hunv, I didn’t notice the bug was also for 6.8.

I just ported the fix also on NS 6: http://dev.nethserver.org/issues/3417

To try it (both on 6 and 7):

yum --enablerepo=nethserver-testing update nethserver-roundcubemail
4 Likes

OK
Tried it today with v7:
From the live-repos its not already included I think.
With using the test-repo it also works on v7.

4 Likes

Released for NS 6.8 and 7.

2 Likes