Anyone getting this error trying to update today?

NethServer Version: 7.3.1611
Module: Updates

Resolving RPM dependencies
The install/update may have failed due to metadata caching issues. Please clean the cache by clicking the button below and retry the install/update operation.

Tried clearing cache a few times and retrying but still getting the same.

Also found this in the logs:

neth pkgaction[18007]: [YumRPMCheckError] [u’ERROR with transaction check vs depsolve:’, ‘nextcloud = 10.0.4-1.el7 is needed by (installed) nextcloud-mysql-10.0.4-1.el7.noarch’, ‘nextcloud = 10.0.4-1.el7 is needed by (installed) nextcloud-httpd-10.0.4-1.el7.noarch’]

Same error here