After upgrade to 7.7 system stuck at 'Starting Switch Root'

I performed a full update of NS 7.6, and then proceeded to upgrade to NS 7.7 via the web interface. The web interface became unresponive to the server and I could no longer ping the system. When I attached a monitor and took a look at the system it was stuck at ‘Starting Switch root’ and would go no further (no logon prompt or any additional informtion appears). I am looking for guidance on how to correct this and either i) proceed to 7.7 or ii) roll back to 7.6. I would like to salvage the system as it has quite a bit of data on it. I have tried all three of the nethserver… options at boot up, but none proceed past the ‘Starting Switch root’ message. I would be happy to try the CentOS recovery option, but am unsure how to proceed.
Longtime reader - first time poster, any help is appreciated.

Thank you.

Welcome Darryl :slight_smile:

Probably something went wrong during the initramfs creation or the server has been shutdown during upgrade.
You should boot in rescue mode and try to recreate it.

Try this guide:

1 Like

So I have tried following the steps in the link provided. I used a NethServer iso, Tools, Recover. I did try option 1 to mount the file systems read-write, then from the shell entered in all the commands from the CentOS link including the ones for CentOS 7. However when I got to the chroot part I encounted an error:
“failed to run command /bin/bash’ exec format error”

My research indicates that this may be a 32 bit vs 64 bit issue, but there isn’t a 64bit only version of the iso, or some other problem.

When I booted to the recovery mode again and tried option 1, it now says ‘no linux partitions found’ so am now afraid that I have really messed something up…

I found an instruction to remove rhgb quiet from the boot up and I have some more verbose information;

5.78992] systemd-journald[105]: Received SIGTERM from PID 1 (systemd).
5.937407] systemd[1]: Failed to execute /sbin/init, giving up: Input/output error

Any additional thoughts?

This looks like a disk problem.

In this case, the only solution is a restore on a new machine (or new disks).

1 Like

I think the problem may stem from the system setup. It is (was?) as software RAID1 on two hard drives. It may be that the commands run didn’t take that into consideration - I should have mentioned more about the setup earlier. I would still like to recover this instalation if possible, but if not, is there some documentation on how to recover this to other hardware>?

Of course: Disaster recovery — NethServer 7 Final

1 Like