After updating with the Nethserver Updater, my Nextcloud installation no longer works

NethServer Version: NethServer release 7.9.2009 (final)
Module: Nextcloud 1.19.0

After updating with the Nethserver Updater, my Nextcloud installation no longer works.

I performed the update via the web, but it failed.
Then started again and the update was successful.
Now comes the request to update again.

An update via the command line does not work because the paths do not exist that would otherwise be different in the Nethserver Nextcloud than with a standard installation.

Thx for help.

Hi, did you take a read on the wiki?

1 Like

thank you, but unfortunately didn’t help.
occ upgrade ran, but the web interface still reports that an upgrade is pending.

occ upgrade
Checked for update of app “workflowengine” in App Store
Starting code integrity check…
Finished code integrity check
Update successful
Turned off maintenance mode
Resetting log level

I had also sent the following command:

occ maintenance: mode --off

Unfortunately I didn’t take an ESX snapshot, and now the whole Nextcloud environment is in place.
Stupid if you just do an update and something like that happens.

I have already tried upgrading via the web several times, although it is not recommended.

Should I try the following?

occ maintenance:repair

[root@mitsrv055 ~]# occ status
Nextcloud or one of the apps require upgrade - only a limited number of commands are available
You may use your browser or the occ upgrade command to do the upgrade

  • installed: true
  • version:
  • versionstring: 22.2.0
  • edition:

What do you mean? Nethserver Softwarecenter?

Which nextcloud version have you installed? Is it nethserver-nextcloud, or did you install manually?
I have installed the nethserver version and did the update with softwarecenter and it works. I’m on version 22.2.0 now.

Yes, with the Nethserver Software-Center.
I would never update Nextcloud manually as this is what the Nethserver developers do and I rely on.

Nextcloud Version now:

  • version:
  • versionstring: 22.2.0

The calendar and address book still seem to be working.

Only not the web interface.
And the Nexcloud Andoid app reports that the server is in maintenance mode.
But the Andoid app may only access the web interface or the API itself?

When I start the update via the web interface, it runs through, says there is nothing to be done, and jumps back to “an update is required”.

However, I had maliciously tried to make the first update attempt conveniently via the web interface, and there were errors here.
The second attempt and via shell everything went through without errors.
But maybe it was too late by then?

Nevertheless, I believe that it may only be a minor thing, otherwise no errors will be displayed.

You can try to reinstall with yum

yum reinstall nethserver-nextcloud

Please do a backup before.

1 Like

Can you access nextcloud after disabling the dashboard app?

occ app:disable dashboard


I thought the dashboard was the entire web interface.
Apparently this is just the start page of the web interface, i.e. an app.
Now that this has been deactivated via “occ app: disable dashboard”, the web interface works again.

Calendar (Thunderbird + Android) and DAVx had already worked before.
That’s why I assumed that not the entire cloud is defective.

Now maybe I can update the app as an admin via the web interface, or uninstall it right away?
This dashboard app was added automatically anyway, and I didn’t explicitly install it.

The first thing now is a snapshot via vCenter.
Never again an update without a snapshot.

Unfortunately, the day before yesterday, the Veeam backup happened to not run, and the last backup is 30 days old.
And I don’t know what happens if such an old cloud is restored and all devices (PCs, Androids, etc.) have a completely different data status, that could end in sync chaos?

yum reinstall nethserver-nextcloud

Here I am afraid of … despite the backup … :slight_smile: :slight_smile: :joy:

Are these messages relevant or can they be ignored?

Thank you so much for your support.

About the dashboard app, you can try to update it from the nextcloud apps (or remove it / add it again if wanted).
The warnings can be ignored, but:

  • you can check the list of invalid files (if they are some leftovers of app updates then they can be manually removed).
  • The one about the region can be “corrected” editing the nextcloud config file (it is described in the wiki).
  • webfinger and nodeinfo warnings, AFAIK can be ignored.
1 Like

Thx for the Infos… :slight_smile:

Remove ist not possible…
[root@mitsrv055 ~]# occ app:remove dashboard
dashboard could not be removed as it is a shipped app
[root@mitsrv055 ~]#