After migration from NS7

NethServer Version: NS8 B2
Module: File Server / Samba

After A Test Migration of a NethServer with AD / Samba:

AD Migration worked, no issues reported.
File Server migration worked, no issues reported.

Access from a Windows10 Workstation works, logging in as Domain Administrator (admin) or another AD user.

Access to migrated shares also works, with one major caveat ( or Bug ? )!

I can read & write as domain admin or as user in this folder, permissions set to domain users.
Even as domain admin, I can’t copy stuff into subfolders, even after setting all permissions (even guest write permissions) for any subfolder… (!)

I can create a subfolder, yes. but I cannot rename the folder, nor do I have any permissions in any subfolders.
I can delete a folder I created, but I can not rename it!

All tried as domain administrator (admin). This seems to occur on several NS8 systems…

Setting full permissions to the folders do not change these issues!

Are any others seeing this in migrated instances from NS7?
Is this a bug (not feature?)… :slight_smile:

My 2 cents


Can you share the migration log?


I will.
Where exactly do I find this?

My 2 cents

1 Like

In ns7 under the Cockpit app interface, or under /var/log something…

1 Like


This should work…

Note: is the NS8 VPN is the NS7 on Wireguard VPN…

Drop me a note if you can’t download the log-file…

1 Like