Adding fstab mappings to core directories

tried mounting to have all shares in our NAS but nethserver 7.0 RC3 seems to reject it. On reboots a number of services including samba and httpd (apache) fail when I add any mappings to core directories. Tried mapping /var/lib/nethserver to a copy on the NAS directory after mounting CIFS (which seems to be okay). any ideas why doing a fstab bind on /var/lib/nethserver, /var/lib/nethserver/home, or var/lib/nethserver/ibay fails on 7 RC3?

Please, share the fstab file contents and post any error message in log files or from the mount command.

Just posted a another entry on a previous post but I’ll add it here too for reference. I think the problem may have been two fold as it seems to be working now:

  1. There may have been some delay in the logging in to the FreeNAS server for mounting. I saw on a couple boots that the directories failed to mount but not consistently. It could have been the frequent reboots on testing perhaps. (Rebooted every change I tried with fstab). A security service was failing before the mount fail as well which lead me to the 2nd part of what I think the issue may have been.

  2. After some research it appears it is expected for the admin to run “signal_event fstab-update” when you make changes to the file. After I did this the security service that was failing was okay. Here is the contents of my fstab:

/dev/mapper/VolGroup-lv_root / xfs defaults,acl,user_xattr 0 0
/dev/mapper VolGroup-lv_swap swap swap defaults 0 0
//(server name)/homes /nasuserroot cifs credentials=/root/freenas_drive,vers=3.0,netdev,comment=systemd.automount,sec=ntlm,filemode=0775,dir_mode=0775,uid=0,gid=0
/nasuserroot/nethserver/ibay /var/lib/nethserver/ibay none defaults,bind 0 0
/nasuserroot/nethserver/home /var/lib/nethserver/home none defaults,bind 0 0

I’ll check the error logs and post them later on. Been a bit busy with work and setting nethserver for final deployment.
Something else that occurs to me: Is NFS better for latency than CIFS for remote mounting? For the FreeNAS Server CIFS was suggested to me but was considering whether NFS may be better.