Add Network Card (USB)

NethServer Version: 7.9
Module: Network


My (Neth)Server, Mini-PC without the possibility of expansion of a plug-in Networkcard., has 2 network ports.
1x red for WAN and 1x green for Lan.
Now I tried to activate another card via USB.

The device is recognized, but as soon as it is configured, all network ports are switched off.
Even the command ifup enpxs0 does not work anymore.
Only the WAN port remains active.

My question now is, is USB networking not supported here by CentOS?

I need a third port for an access point.


Hi @supernicky

Centos7 can handle USB, also for networking.
However, generally, for server stuff, USB networking is rather “wonky” (=unstable).

  • An upgrade can assign a new hw address to the USB interface.
  • Someone brushed against the cable, producing a non-connection - but it looks like it’s connected…
  • Other issues…

In the past, I’ve also had to use a Mac Mini (Single Ethernet, second NIC added via Firewire for Proxmox…
It worked, but I’ve learnt why it’s not the best idea… :slight_smile:

If you really need a third port, it might be sensible to try using a vLAN port…

My 2 cents