AD users not able to login in centos 7

v7
activedirectory

(Sudhakar) #1

NethServer Version: NethServer release 7.3.1611 (Final)


(Sudhakar) #2

I am able to join computers running centos 7 to domain but when i login with domain users screen bounce back to login screen after showing “Creatin home directories”. But with windows systems its working perfectly fine.


(Michael Träumner) #3

Please try to login with ssh first, and have a look if the home directory for the user is beeing created at this moment. After that try to join the computer.


(Sudhakar) #4

Home directory is not created


(Michael Träumner) #5

Have you checked the creation of home directory after windows login?
Then you could try to login an user at a windows-mashine and after that the same user
at a centos mashine.


(Sudhakar) #6

I tried but of no use


(Michael Träumner) #7

Same error with “creating home directories”?


(Davide Principi) #8

Seems like your users have no shell access. If that’s the case, please refer to this thread:


(Sudhakar) #9

davidep your answer seems to solve my problem but now i am gettin “Permission denied” error on login as domain user in centos 7


(Davide Principi) #10

Sorry I don’t understand: can you describe what’s happening? Where do you see the error message? What are you trying to do?


(Sudhakar) #11

when i login with domain user eg. username@domain.local in ssh then i get error “Permission Denied”.


(Davide Principi) #12

Do you get a shell anyway? Or ssh is disconnected after the error?

Please run

sss_cache -E

Then paste here output of

getent passwd  username@domain.local

And try again


(Sudhakar) #13

–admin@domain.local: /var/lib/nethserver/home/admin: change directory failed. No such file or directory
Logging in with home = “/”.
-bash-4.2$


(Sudhakar) #14

this is the error i get when i login with admin user and rest users i get “Permission Denied”. These errors i get when i login with terminal.


(Michael Träumner) #15

Looks like the same error as before, homedirectory is not created.

Could you have a look at the following tutorial:

I think creating the home directories manually and give them the rights manually like in the tutorial could be a try.