Active Sync not working

v7
webtop5

(Riens van Hertum) #1

NethServer Version: 7.4.1708
Module: Webtop

Hi everyone,
I am new to nethserver and nethserver.org

I discovered and installed nethserver last week and have become more and more enthusiastic because of the simplicity of installing and configuring everything and how complete nethserver is. I have the applications NextCloud, Samba and Webtop installed with a Let Encrypt certificate and everything works well except for one thing and that is Active Sync. I have read the manuals, searched nethserver.org and the Internet but cannot find an answer to solve the problem.

https://servername/Microsoft-Server-ActiveSync testing in a browser gives an error message 503 Service Unavailable and in the /var/log/httpd/ssl_error_log I get an error message.
Below a few lines from the ssl_error_log.

All the z-push log files are empty, All services are running like tomcat@webtop, mysql and httpd.
I think I need some help.

Thank you in advance
Kind regards,
Riens


(Jeroen Visser) #2

Could this be SELinux related (this deals with CentOS defaults shipping it with httpd not being able to create outbound connections, as is required for modproxy to work, and would probably not be relevant for a clean install from a NethServer iso) Test is simple:

/usr/sbin/setsebool httpd_can_network_connect 1

As from:
http://sysadminsjourney.com/content/2010/02/01/apache-modproxy-error-13permission-denied-error-rhel/


(Riens van Hertum) #3

Thank you Jeroen for your reply!
When entering the command I get the message 'SE-Linux is disabled’
Problem with Active Sync is the same
The NethServer is a clean iso installation.

Regards,
Riens


(Giacomo Sanchietti) #4

You probably had SOGo installed before WebTop, so you need to switch the ActiveSync configuration.

Execute:

config setprop sogod ActiveSync disabled
signal-event nethserver-sogo-update

config setprop webtop ActiveSync enabled
signal-event nethserver-webtop5-update

See http://docs.nethserver.org/en/v7/webtop5.html#webtop-vs-sogo


(Riens van Hertum) #5

Hi Giacomo,

Indeed I first had SOGo installed before Webtop.
I disabled ActiveSync for SOGo and enable it for Webtop5 but it is still not working.
The error messages are the same.


(Giacomo Sanchietti) #6

Maybe a reload of httpd is required:

systemctl restart httpd

(Riens van Hertum) #7

To be sure I have restarted the NethServer, but no luck


(Riens van Hertum) #8

This is what I see in WebTop, Devices sync greyed out

image


(Giacomo Sanchietti) #9

You’re probably mixing up two different problems.

First, you need to find if requests for Active Sync urls are handled by zpush PHP implementation.
If not, please dig into your Apache configuration because I’m not aware of any bug in this part.

After that, we will see WebTop configuration.


(Riens van Hertum) #10

Yes, you are right
I did hope it was a forgotten configuration setting


(Luca Gasparini) #11

Hi @mvh,
I think it’s better to clarify :wink:

The activation of the synchronization of a calendar you can find it in Edit Calendar -> Synchronization:

WebTop 5  Sonicle Test EAS

By default the initial calendar should have active synchronization.

The items in Customize are inactive because they can only be used on shared calendars.


(Riens van Hertum) #12

Hi Luca,

Thank you for this information!
I checked it and synchronization is Active in WebTop


(Riens van Hertum) #13

Hi Giacomo,

I do have a question, what is the reason why the /var/log/httpd/ssl_error_log is filled with this error messages? Could there be perhaps a problem with the certificate? From outside the certificate works well but could there be perhaps an other problem for the internal requests?


(Riens van Hertum) #14

All I can find is port 20000 will be used but there is no listener on port 20000.
which program or service is missing that should listen to port 20000 ???


(Giacomo Sanchietti) #15

SOGo listens on port 2000. This is why you need to check your httpd configuration: you need to switch from SOGo to WebTop fro Active Sync configuration. The commands I gave you before should do the job unless something is wrong in your machine. :slight_smile:

Please post the output of this command:

grep Microsoft-Server-ActiveSync /etc/httpd/conf.d/*

(Riens van Hertum) #16
[root@nethserver ~]# grep Microsoft-Server-ActiveSync /etc/httpd/conf.d/*
/etc/httpd/conf.d/SOGo.conf:<Location /Microsoft-Server-ActiveSync>
/etc/httpd/conf.d/SOGo.conf:    ProxyPass http://127.0.0.1:20000/SOGo/Microsoft-Server-ActiveSync retry=60 connectiontimeout=5 timeout=3600
/etc/httpd/conf.d/webtop.conf:Alias /Microsoft-Server-ActiveSync /usr/share/webtop/z-push/index.php
/etc/httpd/conf.d/webtop.conf.org:Alias /Microsoft-Server-ActiveSync /usr/share/webtop/z-push/index.php
/etc/httpd/conf.d/webtop.org:Alias /Microsoft-Server-ActiveSync /usr/share/webtop/z-push/index.php
[root@nethserver ~]#

(Giacomo Sanchietti) #17

Did you removed SOGo packages?

If yes, execute:

rm -f /etc/httpd/conf.d/SOGo.conf
systemctl restart httpd

If not, execute:

config setprop sogod ActiveSync disabled
config setprop webtop ActiveSync enabled
signal-event nethserver-webtop5-update
signal-event nethserver-sogo-update

(Riens van Hertum) #18

Hi Giacomo,
Thank you very much, you are the greatest :grinning:

image

Did the job and it’s working now!!!

Thank you so much!