Activate SMB2 on 6.10

Hi, I’m using an old version of nethserver 6.10 constantly updated and Samba version 3.6.23-53.el6_10
I have an issue with SMB protocol still at Version 1.
I tried to put in smb.conf global

min protocol = SMB2

but it doesn’t work.

There’s is a way to let SMB work with protocol 2 ?

NethServer Version: your_version
Module: your_module

@giacomo am i wrong calling for “configuration fragment” here?

@enrilor CentOS 6 (base for NethServer 6) is out of support since December 2020. Therefore… migration could be an important step for have almost 3 years of security updates.

1 Like

Indeed you need a template custom:

mkdir -p /etc/e-smith/templates-custom/etc/smb.conf
cp /etc/e-smith/templates/etc/samba/smb.conf/10global  /etc/e-smith/templates-custom/etc/smb.conf/

Then edit /etc/e-smith/templates-custom/etc/smb.conf/10global, finally apply the config: signal-event nethserver-samba-update.

I do not have an old NS 6 installed, but you could look to man smb.conf to find the correct option.
May be you search for server min protocol and server max protocol.

1 Like