Accounts provider Credentials shall we "put in" in Nehtserver

NethServer Version: your_version
Module: your_module

Hi, I have looked at


for the subject problem, but i am not sure, what i am suppose to put in
Following pics are from my servers , one from Zentyal (Domain controller) and the 2nd from a Nethserver (member server, joined domain perfectly but asking from LDAP credentials).

i have tried a Domain Administrator’s credentials but no luck.
could someone advise, what i am supposed to put as credentials and where to get it from? Pls.

Hello @wdar thank you for posting. I have the exact same setup; Zen as my PDC and Neth joined to the domain via BDC/SAMBA4. You need to either create a new user account on the Zentyal server and give it domain permissions from the web interface (this is what I do) OR you can use the built in Administrator account from the Zentyal PDC but you should first reset the password via the Zentyal web interface. See here.

EDIT - Simple answer to your question is the Bind DN & Bind Password are the same credentials used for joining the Nethserver to the Zen PDC. I apologize I didn’t fully read your question in detail the first go around.

10.0.0.22 Zen-PDC (ad.example.com)
10.0.0.157 Neth-BDC (neth.example.com
addie@example.com - Domain Admin User Account (created)

NethServer -> https://neth.example.com:980
1.Config-> Account Providers -> Select Active Directory -> Next.
2.Join Existing Domain Controller
3a.Enter Full DNS Domain Name // IP address ( ad.example.com // 10.0.0.22)
3b.Enter full Domain username/password (addie is our example here)
3c.I get a second prompt to fill in BIND DN and BIND Password (both are the same username/password used in step 3.a

1 Like

Hi Royce,
Thanking you for replying to my question.

yes, i followed the same procedure.
I have a win 7 machine which is sharing it’s internet coming through wifi and sharing it to member computers through a simple Netgrear 8 port switch. (it is acting as Gateway, DHCP and DNS provider for rest of the network. IP address 192.168.137.1)
Primary domain controller is Zentyal domain controller with file sharing and DNS provisioning (IP address 192.168.137.50/24, DNS 1 :192.168.137.1, DNS 2:192.168.137.1) .
Domain working perfectly, i could join win 10 computers to it using a Domain admin account (freshly generated one. ) however i have to setup the DNS 1 IP address of client PC as 192.168.137.50 and leave the DNS 2 as blank. it gets the random ip from DHCP and let the internet work as well.
Coming to Neth server. installed with one network adaptor as green network, IP address is static as 192.168.137.20 with DNS 1 as 192.168.137.50 and DNS 2 192.168.137.1 . Used the same domain admin account which i used with win 10 client pc to join the domain, it shows me a successful message but tells me to configure Bind DN and Bind password for LDAP applications. Once i supply the same Domain admin credentials as i have used before, it gives me wrong credentials error message.
I restarted both machines again and generated a new domain admin on Zentyal DC and used those credentials but no luck.
Still in the same position.

guidance requested, pls.

In the last step

You need your FULL domain name, so if I create “admin” on Zentyal with Domain Permissions in the last step you would need to enter admin@example.com. Your picture has you entering “root” but this is not correct.

Hi Royce,
with a little of “hit and try” i managed to sort this problem out.
in the last step, put user name as “Domain\user name” in my case it was “w\wdar” and password is the same.
Thanks for your help and patience.

Rock on,

so user@domain.com and domain.com\user both got the same result?

haven’t tried the first one. so can’t say confidently , however for the 2nd option i can say it worked.
i shall be redoing the domain later and will check for it soon.

Hi Royce, i can confirm now that both ways as mentioned in your msg, it worked.