Account provider refused connection

NethServer Version: your_version NethServer release 7.3.1611 (Final)
Module: your_module Account Provider

I’ve completed a fresh install. I’ve configured the server for AD as per the instructions listed in this tutorial: with the exception that I created a vlan to attach the Samba DC to so that I don’t lose the ability to provide internet to the rest of my network. I only have two nic ports, one for red and one for green to serve internal network since the bridge required for Samba DC will stop traffic through the green interface.
Once the DC was running, I then added the following functions in the software center: Basic Firewall,
IPS, NextCloud, Print Server, Virtual Machine Manager.
Once these were installed, I rebooted the server. When it came back up I now get the error “Account Provider Refused Connection”, does anyone have a suggestion on what has caused this? When looking through the logs, there is nothing that I saw that showed an error.
Thanks to all in advance.

I’ve never tested DC with VLAN :thinking:

Why? Sorry I don’t understand…

I have 2 physical interfaces. One is dedicated as a Red interface, the other is a green interface that feeds a switch for my network. When I create a bridge on the green interface it no longer allows traffic through to my network. This was the same with NS 6.8. With 6.8 I could add users and setup the DC without issue, but with 7 the criteria for DC is to assign a different IP and it has to be on a bridged green interface. So I don’t lose the ability to feed the rest of my network I created a vlan to attach the DC to.
Should traffic still flow through a bridged physical interface? With the DC being a virtual container, wouldn’t it work the same way as having a virtual machine running on a vlan that is bridged… being that so long as the vlan is a green network and the firewall allows green to green traffic… it should work?

Not the DC will stop traffic itself, but putting a bridge on a physical green interface will reroute traffic from exiting the interface to the destination of the bridge?

AFAIK the bridge routes ethernet frames automatically… I’m not sure it can work with a VLAN! I’d simply do everything from scratch without VLAN…

Creating a bridge on the green machine doesn’t block any traffic and a VLAN should not be needed.

Let’s assume you have a machine with two interfaces acting as firewall and DC:

  • br0, green interface connected to eth0: this is the interface used from LAN clients to access the internet
  • eth1, red interface connected to internet

The DC will have a virtual interface bridged to br0 and it will be accessible from LAN clients.


I have also installed a no-ip dynamic dns client as per no-ip’s instructions
and requested a Letsencrypt cert based on my dynamic dns domain, which varies from my local domain due to my dynamic dns domain being longer than what is allowed in Samba DC

Fine, this doesn’t affect the network traffic flow :wink:

1 Like

I agree it doesn’t. lol I wanted to include all configuration and I left that part out.

1 Like

This is what I thought should happen, however over the last week I’ve re-installed several times attempting to get it to work but every time I bridge eth0 that feeds my LAN all traffic on my LAN stops. :confused:
I will try and re-install tonight. Thank you both for your assistance, I appreciate i! :smile:

1 Like

Could that be an issue on the switch port?

I’ve changed ports and have power cycled the switch while troubleshooting, but I suppose it could be the switch. My setup is as follows. My modem is connected to eth0 with the IP of NS being reserved my MAC and placed in the DMZ to NS is facing the internet. NS is my firewall, dhcp server, DC, etc… with eth1 then feeding an Asus switch/access point that feeds everything else. When I reinstall tonight I’ll remove the Asus from the equation and see. Honestly though I’m not sure that it is the Asus AP/switch because as soon as I remove the bridge from eth1 then connectivity resumes. I encountered the same problem in NS 6.8 when creating a bridge to run virtual machines in the Virtual machine manager. The easy solution was to create a vlan for all virtual machines, bridge the vlan, allow the routing from the vlan to LAN and it worked and was solid.

If you are running NethServer 7 in a VM please, read carefully this paragraph!

1 Like

I appreciate that information. This install is on it’s own physical machine. The box this is running on is a Dell PowerEdge R410 as a dedicated os

1 Like

Update, reinstalled tonight and everything worked as it’s supposed to… :joy:
I’ll tell on myself on this one for a laugh… I’ve re-installed at least 4 or 5 times in the last week trying to get it to work with DC, and I failed every time. Tonight I re-installed and everything came up the first time without any trouble at all. Thanks to everyone for their help, and thank you for the extremely quick response this morning when I originally posted.