Account provider - No binding for Roundcube

roundcubemail
activedirectory
v7
mail

(Massimo Bettini) #1

**NethServer Version: 7.3.1611
**Module: Email + Account provider

I am taking advantage to a local holiday to test NS7 and Esxi on an old workstation; this in view of a future upgrade of our office’s server from NS 6.9 to 7.3.
My current setup is :

  • Workstation : Dell Precision T5500 (Xeon + 6GB RAM + 500 GB Disk)

  • Virtualization environment : Esxi 6.5 U1 (running from USB)

  • Account provider : Samba 4.4 installed on Ubuntu 16.05 LTS (VM)

  • Netserver : NS 7.3.1611 installed on CentOS 7.4 (VM)

The AD PDC is installed correctly and runs as expected in 192.168.1.X subnet; so much so that I can administer it (add users, groups and manage policies) using RSAT on a WIN10 PC :

After installing NS7, I successfully bound it to the Samba AD; users and groups are visible :

The problem I am facing is that, despite having created the dummy user for the read only bind, Roundcube does not show the LDAP address book. I tried several combinations (short user name, long user name, etc.) but the result is always an empty address book.
I checked that all users are configured properly and their account can be accessed without any problem.
Email is also working.

The logs seems to suggest of an authentication problem :

Does anyone know how to solve this issue?

Thank you in advance

Massimo


(Markus Neuberger) #2

Hi @maxbet,

you may try to add this line to global section of your SMB.conf on your AD server:

This workaround allows unencrypted connections.

Source:


(Massimo Bettini) #3

Markus,
that solved the issue. Now Roundcube shown the public address book, as per LDAP.
Thank you very much

Massimo