Accessing shared mailboxes fail

NethServer Version: 7.9.2009
Module: SOGo


I’m currently evaluating NethServer and running into some issues with shared mail folders.
One issue is mentioned here:

All users cannot access the shared mailbox folder, the error message is 'An error occured while communicating with the mail server".
Furthermore, when a user shares a personal folder with another user this folder does not show up in the other user’s browser.

I assume both issues are part of the same permisson problem.

Apr 24 16:25:00 sogod [2079]: [ERROR] <0x0x55ffdd6cb6a0[NGImap4Connection]> could not select URL: imap:// {RawResponse = “{ResponseResult = {description = " Permission denied (0.001 + 0.000 secs).”; flag = NOPERM; result = no; tagId = 9; }; }"; access = NOPERM; reason = " Permission denied (0.001 + 0.000 secs)."; result = 0; }
Apr 24 16:25:00 sogod [2079]:, “POST /SOGo/so/admin/Mail/0/folderPublic/view HTTP/1.1” 500 72/48 0.366 - - 0 - 15

Is there any structural solution to this problem? Suggestions in other posts do not work. It looks like it’s been around for quite a while. I really need to have this fixed since most user over here make a lot of use of shared (personal) mail folders.

Note: when I create a public mailbox and set ACLs all users can access this mailbox. It’s just that personal shared mail folders don’t end up in the Shared Mailbox section. Is there any way to set permissions on the top level?


Hi and welcome to NethServer Community.

To share for the inbox for example, you need to go to “Sharing…”:

Add a user and set permissions: (Any authenticated user didn’t work my test)

That’s it, now the folder should be visible under “Other users”:

I am aware of the procedure on how to set it up but it doesn’t work. Probably an issue with permissions, resulting in the error message I mentioned before. The shared folder doesn’t show up in the mailbox of the added user. There is no “Other Users” folder as well.


I guess the first error occurs because you were trying to open the “Shared Folders” root, where you don’t have access by default but you can access the subfolders.

To fix it you could change the permissions of the Public folder:

As regards the second error, I tried to reproduce it on a fresh install and it just worked.
Did you already try to allow all permissions to the mailbox accessing user?

Thanks you for your reaction. I already gave full permissons to the user with no effect. Shared folders still invisible. You say that you are succesful with a clean install. In my config Nethserver is added to MS Active Directory, user accounts are configured there. I also (need to) use multiple virtual mail domains. The default installallation domain name is not being used, all communication goes via a virtual mail domain. The user’s default imap identity therefore is not ‘’ but ‘user@virtual.domain,name’. Perhaps this setup could be on any influence on the test results?

I could live with the root public folder not being accessible as long as the shared mailboxes are accessible as sub folders. And that is working. The only point of critisicm I have is that all shared mailboxes are visible to all users, even if they have no access to it. This will confuse most users, especially if you have a lot of shared mailboxes and the user has access to only one.

But the shared folder thing is quite a show stopper. Any other pointers where I could look?


I’m beginning to supsect is has something to do with dovecot not picking up the (virtual) email address read from the user email attribute in AD. The local email domain (from install) is different from the AD email domain.
For example, the local user email address is and the email address from AD is In NethServer ‘’ is a virtual mail domain. When I try to share a mail folder with this user I can only select the AD account ‘’. This email address does not exist on the local file system. Could this be the cause of the issue? If so, is there a way to tell dovecot to accept this domain?

You could try to edit the AD mail address and check if it works:

FYI, in my setup NethServer is a member server in a MS Active Directory environment.
The user UPN was already changed to @<>. The UPN is the same as the e-mail address from the user email attribute. In Nethserver I created a virtual mail domain “”. Nethserver created user mailboxes named @<> so I created aliases for the users named @<>. So far so good. Everything is working really well and users can use SOGo based on their @<> address. Apart from the sharing functionality that is. So your suggestion about changing the UPN was already in place. To me it seems as if SOGo doesn’t pick up virtual mail adresses, i.e. aliases or can’t make a connection between the mail alias and the actual mail address.
Is there a way to troubleshoot SOGo and see what it’s trying to do when you share a mail folder?