Access the web interface

server-manager

(Valeriy) #1

I can not access NethServer https://192.168.15.3:980/
Can not access site
The 192.168.15.3 site does not allow you to establish a connection.
Try the following:
Today, access to the web interface of the server was lost.
Check your Internet connection.
Check the proxy server and firewall settings.
ERR_CONNECTION_REFUSED

if you enter
https://192.168.15.3

I see the inscription
Congratulations, your NethServer installation is up and running!

P.S. I rebooted the server and selected the previous kernel. Access appeared.


(Marc) #2

It could also be due to httpd-admin service not running (failed) or the port unreachable.
Anything relevant in the logs at that time?
Which kernel version? Is it reproducible?

Could have the firewall blocked it?


(David Gordon) #3

I had this problem. I solved it by opening port 980 on my router.


(Henry Buitrago) #4

I have the same problem that Valery. It was before actualization. The follow message is showing
Nethgui:
500 - Internal server error
1366796122+1322738020
Can somebody help me, please? Thanks in advaced. Henry


(Marc) #5

When accessing the server-manager you see a white page with the 500 error?
In that case I guess httpd-admin service is running, but doesn’t hurt to check it:

systemctl status httpd-admin

Which modules are installed?

rpm -qa nethserver-\*

(Hector Perez) #6

is ssh working? check what @DavidG said with the sub-network and routing .


(Marc) #7

Is the filesystem writable (can you create a folder or a file on it) or is it read-only?
Maybe @planet_jeroen server problem is related to what both of you also reported.


(Jeroen Visser) #8

These are the exact same symptoms I experience. If I boot the newest kernel (default), I end up with read only filesystem. If I boot the previous kernel, it is writeable, and everything works. (I just experience a Firefox hickup then, but IE works in that case)

With the newest kernel, almost nothing starts due to write-issues.


(Marc) #9

I’m using that kernel on some test VMs apparently without problems.
Anything relevant from journalctl?


(Jeroen Visser) #10

Given:
afbeelding

journalctl’s first error indicates:

Editing the default grub entry:


The entry below it, is identical, except for the kernel used:



Booting that, journalctl returns nothing of interest.


(Marc) #11

XFS (dm-0): unknown mount option [acl]

Same error as this older bug:

Can you share your /etc/fstab file?


(Henry Buitrago) #12


Thanks Marc, for your prompt answer. Maybe this docs will can help. Tks Henry


(Jeroen Visser) #13

…removed the obvious part from that file;

…removed the other (now) also obvious part (requiring reboot to previous kernel), and all seems well.
Need to see what this does for shares and the like.


(Marc) #14

You’re getting the same error as @Imre_Bertalan, but in his case I believe it was due to a power outage.

[EXCEPTION] UnexpectedValueException 1322738020: Nethgui\\Utility\\Session: only \\Serializable implementors can be stored in this collection! (in /usr/share/nethesis/Nethgui/Utility/Session.php:163)

Although the error leads to some bug in the code.


(Marc) #15

If you removed the acl and user_xattr attributes from the XFS partition it should be ok.
So other user’s problems could be unrelated at last.


(Jeroen Visser) #16

looks good indeed. Needs some testing, but thanx!

@ the issue in this topic: I had this error as well … it went away when I used another browser. Seems to be a certificate cache issue, possibly to do with how Firefox handles stapling, or how Nethserver does.

Different firefox works fine, perhaps I needed to restart the browser, and perhaps this might be your issue as well … of not, I sadly can not be of help.


Port 980 error on installation
(Henry Buitrago) #17

I finally solved the matter:
I use Mozilla. By Menu / Options / Privacy & Security, in exceptions I add the web address with the port. Works. Thanks partners, by… Henry