Access from windows denied on samba linux client

Hello everyone, a few days ago I haven’t been connecting windows machines to AD-accredited linux clients. The reverse happens, the linux machines I can browse the windows network entering the machines. Windows PCs no longer, even older ones (Xp windows 7 and more).

I noticed this error in the logs :slight_smile:

I tried to redo the join but nothing.

gen 08 22:37:15 lxle smbd[4261]: connect_to_domain_password_server: unable to open the domain client session to machine NSDC-NETH7.AD.INTERNAL2.LAN. Error was : NT_STATUS_CANT_ACCESS_DOMAIN_INFO.

I know back in the day there was an issue with NetBIOS allowing max of 15 characters but we don’t use NetBIOS anymore unless I’m mistaken about xp and win 7 could you try the rejoin again but just put in ad.internal2.lan see if that works

If there still joined but not connecting don’t forget to remove them from ad first

Hi @Shane_Treweek

The 15 Chr limit is still valid in Windows - for Hostnames and AD-Domainnames.
DNS names are less restricted - 254 chrs…

Even if NetBIOS is “hardly” used, it’s limits are still valid.
Your Windows box probably doesn’t have a serial port or a parallel printer port, yet on the C-Disk toplevel, you still can’t create a folder caller ser, lpt1, nul, etc. These are still reserved names in Windows, although USB isn’t one!

All the above are still valid for Windows 11 and the latest server systems…

My 2 cents

1 Like

good to know

Ok, thank you, but all this has always been in production. However, I wanted to know considering that the neth server forest is 2008 Windows Server, wanting to re-accredit linux PCs it is better to use Winbindd or even sssd (even if not compatible with samba on some protocols). ?

Hello everyone, after several attempts I gave up. I tried to reconfigure a new car, however, with the Winbind procedure and not SSSD. Everything works at the moment, but I keep it on test. Thank you all.